0

I have just installed ubuntu 14.04 and my wifi networks are not showing. I do not have the broadcom wifi driver in my settings and I've tried the mediatek wifi adapter, but I get "modprobe: ERROR: could not insert 'mt7630e': Required key not available" when i run the install command. Here are excerpts from when my wireless-info file

##### rfkill ############################

0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no


##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

Please help!

marked as duplicate by Pilot6, chili555 wireless Jul 19 '16 at 21:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Short answer: Disable Secure boot. – Pilot6 Jul 19 '16 at 19:18
0

Ensure WiFi is set as an active device in the Network settings. While your computer has a WiFi card, it's function may not yet be turned on in your Ubuntu (it is common for this to be so). Once you have turned it on it will remain as such unless you or a system update requires it be turned off, in which case you only need to turn it on again). You did not supply us with the specific Asus computer you have, but there is almost certainly a switch or button to turn it on and off on the outside of the computer. Ensure it is turned on and select a WiFi network in your Network settings window and all should be fine (but if your hardware is of a type not commonly installed automatically then you must install it and reboot). This command will define which WiFi card you have (or at least the way it's seen by Ubunut) sudo lshw -C network . If this does not resolve your issue then please post the output of that terminal command here for us. For Broadcom specificly, here are Ubuntu's instructions for this brand's WiFi devices: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

Not the answer you're looking for? Browse other questions tagged or ask your own question.