0

This is could be a database issue but to check if related to network configuration.

To start DB i USE :

Running rethinkdb 2.3.4~0trusty (GCC 4.8.2)...
Running on Linux 3.19.0-39-generic x86_64
Loading data from directory /root/rethinkdb_data
warn: Cache size is very low and may impact performance.
Listening for intracluster connections on port 29015
Listening for client driver connections on port 28015
Listening for administrative HTTP connections on port 8080

Can the see the output states that 'Listening for administrative HTTP connections on port 8080'

But when I attempt to connect to this port using server IP address over http the request times out. So it appears the port is not open,

I run netstat -tuplen and receive :

Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode       PID/Program name
    tcp6       0      0 :::8080                 :::*                    LISTEN      0          871572      21433/rethinkdb 

local address of 0 :::8080 should be 127.0.0.1:::8080 or localhost:::8080 ?

Are there other command I can try to diagnose this issue ?

  • That's a TCPv6 socket. You don't use IPv4 addresses like 127.0.0.1 with that. :: means it accepts connections from any network interface. ::1 means it accepts connections only over the loopback interface (so, localhost). – Olathe Jul 19 '16 at 17:38
  • @Olathe '::1' should be ':::' as ::1 is not in netstat output ? When check ip address on machine it is in ip4 format : 12.23.34.21 , so how can I connect to it ? – blue-sky Jul 19 '16 at 19:28
  • What bind option(s) do you have in the conf file? it looks like at one point there was an issue with bind=all only binding to IPv6 addresses - see bind=all does not bind to IPv4 addresses – steeldriver Jul 19 '16 at 20:15
  • @Olathe please see question update – blue-sky Jul 19 '16 at 20:57
  • @steeldriver please see question update – blue-sky Jul 19 '16 at 20:57
0

Comments below were a big help. After reading https://github.com/rethinkdb/rethinkdb/issues/1897 I tried disable ipv6 by following :

How to disable IPv6 in Ubuntu 14.04?

This did not seem to have an impact.

Last comment of : https://github.com/rethinkdb/rethinkdb/issues/1897

"Hi, @danielmewes yes you are right, my problem was iptables, i dont know why, but this time was iptables blocked the 8080. Last month i installer another rethinkdb cluster on centos 7 minimal install and I didn't had any trouble with iptables, but this time i had. Probably because last install configure the firewall exception and this new version don't.

Thank for your response.

Sergio"

This appears to have been my issue also as unblocking the port 8080 allowed me to connect to admin UI on port 8080. Command to unblock port 8080 with iptables :

sudo iptables -I INPUT -p tcp -m tcp --dport 8080 -j ACCEPT

and start server : rethinkdb --bind all

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.