0

This question already has an answer here:

I'm unable to install wine in ubuntu 16.04.

sudo apt-get install wine

is giving me this error

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

Please help soon

The following packages have unmet dependencies:
 wine : Depends: wine1.6 but it is not going to be installed or
                 wine1.8 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

marked as duplicate by karel, Fabby, user535733, Eric Carvalho, waltinator Jul 3 '18 at 13:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • If you have not tried to install wine before (or if you cleaned up the mess from failed attempts), then it's a simple sudo apt install wine. The real question is what prior attempts you made, and what PPAs and other non-Ubuntu sources you used, so we can advise you how to clean up the mess. – user535733 Dec 23 '17 at 4:06
0

You need to go one-by-one and install each of these dependencies to see what the problem is:

sudo apt-get update
sudo apt-get install wine1.6-i386
sudo apt-get install wine1.6
sudo apt-get install wine

Please post any errors, thanks.

  • @catch_me first, determine which version of wine you need to achieve your goals Second, if you need a specific wine version, I suggest looking at the Wine PPA channels – user175999 Jul 19 '16 at 6:28
  • @user175999 This seems pretty irrelevant to the error. When you go to install the specific versions explicitly, there should be an additional error describing what is impossible about the situation. Most of the time there is no specific version needed and ppa is not recommended unless that is the case. – mchid Jul 19 '16 at 6:33
  • it is important because to determine the necessary steps to provide a solution, we need to know which packages to remove and un-break in some kind of package manager – user175999 Jul 19 '16 at 6:35
  • @user175999 That's what I'm doing and I'm an expert at package management and haven't met a broken package management setup I couldn't fix in at least a couple of years now. – mchid Jul 19 '16 at 6:36
  • never said your answer was wrong...just saying that there are other ways to the same destination – user175999 Jul 19 '16 at 6:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.