23

Greeting. I am on ubuntu 16.04 LTS. It is an amazon EC2 instance I got grey screen upon installing and starting the vncserver I try many suggestion regarding this issue but still cant get it work.... Thanks for the help

enter image description here

My logfile:

Xvnc Free Edition 4.1.1 - built Feb 25 2015 23:02:21
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 40300000, The XFree86 Project, Inc
Tue Jul 19 03:03:37 2016
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0
error opening security policy file /etc/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/75dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi/, removing from list!
Tue Jul 19 03:03:44 2016
 Connections: accepted: 0.0.0.0::61550
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)
Tue Jul 19 03:03:50 2016
 VNCSConnST:  Server default pixel format depth 16 (16bpp) little-endian rgb565
Tue Jul 19 03:03:51 2016
 VNCSConnST:  Client pixel format depth 8 (8bpp) colour-map

my xstartup

#!/bin/sh
# Uncomment the following two lines for normal desktop:
 unset SESSION_MANAGER
 exec /etc/X11/xinit/xinitrc
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
gnome-session &
22

I had the same issue on Ubuntu 16.04 LTS (64bit). I updated ~/.vnc/xstartup file to look like below, worked successfully for me.

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &

gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &

Reference: https://www.linode.com/docs/applications/remote-desktop/install-vnc-on-ubuntu-16-04

  • 4
    This was a partial fix for me. Nautilus loads just fine but that is all I have. I do not see the icons along the left and I do not see any way to launch any programs, not even a terminal. If this helps at all, when I issue 'echo $DESKTOP_SESSION' it returns an empty string. – Adrian Hood Sr Apr 26 '18 at 19:54
  • 1
    I had to install gnome-panel via sudo apt install gnome-panel, but once I did that it worked. – pheeper Aug 15 '18 at 15:38
8

I had the same issue. To resolve it, I installed:

$ sudo apt-get install gnome-panel gnome-settings-daemon metacity nautilus gnome-terminal

Then I added the lines below to ~/.vnc/xstartup:

gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &
  • 1
    and then don't forget to kill and restart the vncserver (like I did) – craq Sep 3 '18 at 4:56
2

For anyone experiencing this problem on Xubuntu 16.04 LTS, I got my tightvncserver working by editing ~/.vnc/xstartup to this:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
# Fix to make GNOME work
#export XKL_XMODMAP_DISABLE=1
#/etc/X11/Xsession
# fix to make xfce work:
startxfce4 &

The first two commented-out lines were already commented out presumably by the packager. I commented out the two lines following "fix to make GNOME work", and added the last two lines, so it can be shortened to just

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
# fix to make xfce work:
startxfce4 &

Again, this applies specifically to Xubuntu, not Ubuntu with Unity or Gnome.

2

Not mentioned in any of the answers at the time of writing: it is also worth noting that the xstartup file needs to be executable:

chmod +x ~/.vnc/xstartup

If not, the grey screen issue continues to occur regardless of the contents of the file.

1

Just had the a similar problem and found a solution which I have not seen in any articles I read over the past few days trying to sort this out.

In addition to @Waqas answer I had to make sure I own all files in my home folder. Clearly this is about some specific files but I did'nt have time to check this out

sudo chown user:user /home/user

Just thought it might help somebody.

0

My xstartup config file already had following lines which were commented out by default.

# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc

un-commenting them fixed the problem and now i can access my desktop via vnc client smoothly. it still launches terminal window at logon but if you exit that then it shows the usual desktop via vnc.

0

I had the same issue, but found ~/.vnc/xstartup.bak to have my old config. I just needed to:

cp ~/.vnc/xstartup.bak ~/.vnc/xstartup
-1

I finally got this working from vnc4server by "apt-get install xfce4", and found a working xtartup here (the rest of the tutorial was irrelevant for my needs, e.g. "apt-get install xfce4-*" was unneccessary): http://www.itzgeek.com/how-tos/linux/ubuntu-how-tos/how-to-install-vnc-on-ubuntu-16-04.html

#!/bin/sh
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
startxfce4 &

I've more or less concluded getting gnome to work in vnc is a non-starter.

-1

I had the same issue after upgrading from 12.04 via 14.04 to 16.04. The essential tip that helped me was to install gnome-panel. Ref: http://www.linuxforums.org/forum/ubuntu-linux/209177-vnc-grey-screen-hi-res.html

sudo apt-get install gnome-panel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.