13

I have a failed install of Hp printer at http://hplipopensource.com/hplip-web/install/manual/distros/ubuntu.html What I need help with is how do I Delete the printer software so I can reinstall. Also am I python 2 or 3? in 16.04 64 bit? I accidentally downloaded HPLIP double clicked the file and got an error message and clicked continue. Then I attempted a manual install i got

:~$ sudo hp-setup
[sudo] password for  

HP Linux Imaging and Printing System (ver. 3.16.3)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

Also,

I had an error when using: Ubuntu 15.10 and 16.04 in python3 environment:

seemed to run when i used: Ubuntu 12.04 and above in python2 environment:

I have no idea whether I am python3 or python2.

I think once I know whether I am python3 or python2 I need to know how to completely uninstall my mistakes and then attempt a reinstall. I am a beginner so I may need to cut and paste the code for deleting my messed up install.

I am installing a HP officejet pro 8600. I can scan with simple scan and I print with my brother laserjet. Should i give up and just use simplescan since my 8600 does not even have ink. I was trying to get better scanning software.

Thank you for looking and any help.

Jon

2
  • 1
    as the problem itselft states error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode. have you tried that? I mean try running with sudo hp-setup -i or sudo hp-setup --qt3
    – Techjail
    Jul 19 '16 at 2:32
  • I don't really know what you're talking about Python here, but if this is a separate, unrelated issue, it should also be asked in a separate question. Thanks.
    – Byte Commander
    Jul 19 '16 at 7:09
21

you should run this

sudo apt-get install python3-pyqt4

and for Ubuntu 18.04, you will need both pyqt4 and pyqt5

sudo apt-get install python3-pyqt5

font: https://help.ubuntu.com/community/HpAllInOne

1
  • 1
    In case of a fresh install of Linux Mint 19.3 the only thing required was "python3-pyqt5". Jul 12 '20 at 9:56
2

It looks like it is complaining about stuff that should be installed. Actually, you should not have to "download" anything as all of this stuff is available through apt-get.

Run the following commands to install all needed software and drivers:

sudo apt-get update
sudo apt-get install hplip hplip-data hplip-doc hpijs-ppds hplip-gui hplip-dbg printer-driver-hpcups printer-driver-hpijs printer-driver-pxljr

Now, run one of the following commands:

/usr/bin/hp-setup --gui

or if that fails due to permission issues, run this instead:

sudo -i /usr/bin/hp-setup --gui

This version, 3.16.3, is the same version available from the hp website.

Please post any errors.

3
  • Unable to locate package hplip-dbg
    – Ben Farmer
    Mar 11 '19 at 20:14
  • @BenFarmer That's just a debugging package and it looks like you can get it running without it and the package has probably been depreciated and/or merged with the main hplip package. Go ahead and delete that package from the command and try again and please post any more errors. Thanks!
    – mchid
    Mar 12 '19 at 6:35
  • @BenFarmer The following command will search for and install all of the available packages according to your current distro: sudo apt install $(echo $(apt-cache search hplip | sed 's/ - .*$//g'))
    – mchid
    Mar 12 '19 at 6:41
0

There seem to be a number of factors, including those shown in other answers. I have just set up an HP LaserJet Professional p1102w on 2 almost identical Slimbooks running KDE Neon and the problems were subtly different, so it seems to depend partly on the history of the machine. In my case although the installations completed without any apparent errors, when I tried to print they always gave a "Filter failed" message.

Things to look at include

1 Make sure hplip is installed.

2 Try to install using hp-setup. This may work but likely it won't.

If it complains about the GUI, do as in the post from João Lucas Gouveia:

3 sudo apt-get install python3-pyqt4

4 Use hp-doctor to diagnose. In my cases I had a problem with access to the .ppd file, so

5 sudo chmod a+rwx /etc/cups/ppd/*

Although this got rid of one error message it still didn't get the printer working, so

6 Run hp_doctor again. It offered to remove and reconfigure HPLIP, so I took that option. The result: Success!

0

Mix of all, I have used more than two answers here. After finding more resources the best way to fix the hp-printer faile is that

Step 0: Make sure you have installed USB drivers, and your Printer is plugged and is ON

Step 1: sudo hp-check -r run this code in Terminal to find all the errors, list of dependencies, warnings at once

Step 2: for Ubuntu 14.04

sudo apt-get install python-qt4

for ubuntu 15.04 and 16.04

sudo apt-get install python3-pyqt4

for newer versions till 18.04 you might have to run both below codes

sudo apt-get install python3-pyqt4
sudo apt-get install python3-pyqt5

Step 3: run the below code after altering the code depending on the list of required dependencies you got when you ran sudo hp-check -r (ref)

sudo apt-get install --assume-yes libcups2 cups libcups2-dev cups-bsd libdbus-1-dev libjpeg-dev cups-client libcupsimage2-dev libusb-1.0.0-dev libsane-dev libsnmp-dev snmp-mibs-downloader openssl python3-dev libtool libtool-bin gtk2-engines-pixbuf xsane python3-dbus.mainloop.qt

Addons its always best to delete all the files inside (ref)

/var/spool/cups

and to restart your printer service

sudo systemctl restart cups.service

FYI:

  1. these above steps can also fix ("Printer State") always shows "Stopped - Filter failed" or something like "job-printer-state-message filter failed"

    1. You can find information for all HP printers with below code

    hp-info -i

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.