22

The soundcard I want to use is detected and works (it only recently switched to dummy output and didn't allow me to go back).

HDMI is no longer listed under Audio and Video - KDE Control Module; everything under audio module is set to dummy output and its the only 'soundcard' on the list now. I can view my previous sound cards in alsamixer, but changing the settings from there does nothing.

How can I get my real soundcards to work again?

I have already tried the following answers without success:

How do I get my sound working?

EDIT:

name@name-desktop:~$ lspci -vvv | grep -A8 Audio
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri HDMI/DP Audio Controller
        Subsystem: ASRock Incorporation Kaveri HDMI/DP Audio Controller
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 43
        Region 0: Memory at ff764000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
--
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
        Subsystem: ASRock Incorporation FCH Azalia Controller
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at ff760000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel

Could this image possibly help?:

enter image description here

There is another soundcard but I'm unsure of what its for because it never outputs sound, but it does have a lot of settings: that sound card is labelled as "HD-Audio Generic".

enter image description here

enter image description here

So I went into Software & Updates under the Additional drivers tab and I see this:

enter image description here

It was on Do not use the device so I changed it and applied the settings but unfortunately the soundcard isn't back even after reboot.

19
  • What type of computer do you have?
    – mchid
    Commented Jul 18, 2016 at 23:39
  • Built it myself so its custom; which parts were you concerned about?
    – HelpMeee
    Commented Jul 18, 2016 at 23:40
  • Well, I saw this other answer related to dell askubuntu.com/questions/460035/…
    – mchid
    Commented Jul 18, 2016 at 23:41
  • 1
    Please run the following command and post the output in your question to help, thanks. lspci -vvv | grep -A8 Audio
    – mchid
    Commented Jul 18, 2016 at 23:44
  • Try running the following command and then reboot: usermod -a -G audio $USER
    – mchid
    Commented Jul 19, 2016 at 0:08

11 Answers 11

11

I don't know what's the problem or why it happens, but that worked for me.

pulseaudio --kill
pulseaudio --start
0
9

First, replace any previous configurations:

sudo apt update
sudo rm -R /etc/pulse/*
sudo apt-get -o DPkg::Options::="--force-confmiss" --reinstall install pulseaudio

Then, run the following commands:

sudo apt-get install --reinstall linux-image-$(uname -r)
sudo modprobe snd-hda-intel
rm -r ~/.config/pulse*
pulseaudio -k

source


If alsa is somehow messed up, then running the following commands may fix the issue:

sudo apt update
sudo apt -o DPkg::Options::="--force-confmiss" --reinstall install libasound2 libasound2-data libasound2-dev libasound2-plugin-smixer libatopology-dev libatopology2 alsa-utils pulseaudio
rm -r ~/.config/pulse*
pulseaudio -k
13
  • PulseAudio Sound Server is now in place of Dummy output in the Audio and Video - KDE Control Module as a audio playback device , but it still says "Dummy output" in the tray, but that might be just a display issue.. not sure. Either way, system sound test still outputs no audio. Also my original soundcards are still not back. I actually had the PulseAudio Sound Server situation before, and thats what made me try to uninstall it.
    – HelpMeee
    Commented Jul 19, 2016 at 1:31
  • 1
    I'll reboot in about two hours to look for improvements (currently waiting for files to finish downloading).
    – HelpMeee
    Commented Jul 19, 2016 at 1:39
  • Rebooting actually changed the PulseAudio Sound Server back to Dummy Output :( Sorry to disappoint
    – HelpMeee
    Commented Jul 19, 2016 at 2:10
  • 2
    @HelpMeee Try running commands 2, 3, & 4. According to the thread, some people have to modprobe snd-hda-intel after every boot.
    – mchid
    Commented Jul 19, 2016 at 2:22
  • Yes, its back to PulseAudio Sound Server, but its still Dummy Output everywhere else and there's no sound.
    – HelpMeee
    Commented Jul 19, 2016 at 2:24
4

There doesn't seem to be a solution to this so I just re-installed Kubuntu and the sound works perfect.

Downside: wiped everything else (but I didn't have much on my ssd so it was fine)

1
  • 2
    That's like saying "My tire went flat, so I bought a new car"
    – kurdtpage
    Commented Apr 15, 2023 at 9:30
1

For those using the snd_hda_intel module

  1. Check if you are using the snd_hda_intel kernel module:

    lsmod | grep snd_hda_intel
    lspci -nnk | grep -A2 Audio
    
  2. If so, add two lines (you may need only the first line) to alsa-base.conf using the commands below.

    echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf
    echo "options snd-hda-intel dmic_detect=0" | sudo tee -a /etc/modprobe.d/alsa-base.conf
    

NOTE: It was suggested to also add a third line but my system worked without me adding it. Add that using this command:

echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/blacklist.conf

REF: Fix No Sound (Dummy Output) Issue In Ubuntu With SND HDA Intel

1

For me, the problem was caused by one application that locked the sound device. In my case, it was mplayer, but it could be something else for you. To get a list of these applications, run:

# fuser -v /dev/snd/*
                     USER       PID ACCESS COMMAND
/dev/snd/controlC0:  ...      899378 F.... mplayer
/dev/snd/pcmC0D0p:   ...      899378 F...m mplayer
/dev/snd/timer:      ...      899378 f.... mplayer

After stopping that application, I forced a restart of pulseaudio:

/usr/bin/pulseaudio -k && sleep 1 && /usr/bin/pulseaudio --start

For more details, please check the Arch Wiki, where I found the trick:

The only device shown is "dummy output" or newly connected cards are not detected

If the only playback device is the Dummy Output, PulseAudio cannot access your sound devices. It is possible there is an issue with logind giving permissions, see General troubleshooting#Session permissions for more information.

An application might also not have been configured to work with PulseAudio. This happens with FluidSynth for example. To see which application is responsible for a direct access to the sound card via alsa, run the following command:

# fuser -v /dev/snd/*

Try to close these applications. pulseaudio, if running, should take again precedence over these applications and all the applications relying on pulseaudio should work again like expected.

1
  • 1
    Thank you so much for this answer. This solved the problem for me - and it was indeed fluidsynth causing the issue.
    – gregoryg
    Commented Jan 2, 2023 at 20:27
0

If you only care about analog stereo, a very simple solution is to use a C-Media USB audio device. My built in audio card is just not detected. The problem may be with my motherboard because it used to work. If I wanted to use 5.1 I guess I could buy a card.

0

There can be many different causes of this problem, but I'll give an answer for my particular situation. I started experiencing this after upgrading to Ubuntu 20.04 from 18.04. The problem turned out to be permissions. My account was in the pulse-access group in /etc/group. For 18.04, this was sufficient. It appears that for Ubuntu 20.04 there was a change such that the account must now be in the pulse group instead.

0

Go to Settings > Software & Updates > Additional Drivers. You will find a driver similar to audio: set it to Do not use this device. Then apply changes and restart.

Then system will use the inbuilt audio

If not working check whether it has changed by repeating the above.

0

In my case:

Settings > Multimedia > Audio Volume > Advanced and there switching around between 4.1 and Analog Stereo Output/Duplex

Sound is back...

0

I solved this on my E200 HA by putting the following lines in /etc/modprobe.d/alsa-base.conf

options snd-usb-audio index=-2
options snd-hda-intel mode="olpc-xo-1_5"

The first stopped the dummy output and got the soundcard recognised, but I had to put in the second line as sound was coming out of both speakers and headphones at the same time.

0

Today - seemingly having the same problem - I did the following, using Synaptic package manager:

Reinstalled the following packages:

linux-sound-base (1.0.25+dfsg-0ubuntu5)
pulseaudio (1:8.0-0ubuntu3)

... and my card is back available.

Edit: problem came back after reboot!

Edit2: minimal (temporary) remedy is sudo dpkg-reconfigure pulseaudio

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .