I clean installed Ubuntu 16.04 today. All seems to be working fine except Wi-Fi. The drop down menu shows no Wi-Fi connection option.

  1. I did a rfkill list -

Wireless LAN Soft blocked: no Hard blocked: no

  1. Then tried lshw -class network -

*-network Description: Network controller Product: QCA6164 802.11ac Wireless Network Adapter Vebdor: Qualcomm Atheros Physical id: 0 Bus info: pci@0000:02:00.0 Version: 20 Width: 64 bits Clock: 33 MHz Capabilities: bus_master cap_list Configuration: driver=ath10k_pci latency=0 Resources: irq:39 memory:f0800000-f09fffff

  1. Tried almost every solution provided here - Can't view Wifi networks after upgrading to Ubuntu 16.04

I think somehow either Ubuntu is not detecting my Wi-Fi hardware or I don't have the sufficient driver to get it working. Please help me.

N.B. - Since my laptop has no internet connection, I had to type every details through my phone. So any mistake is regretted.

1 Answer 1


Please download this file on some other computer and transfer it on a USB key or similar: http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.158_all.deb

Drag and drop it to the desktop of your Lenovo. Open a terminal and do:

cd ~/Desktop
sudo dpkg -i linux-firmware*.deb

Reboot and let us know if it is now working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.