0

I just installed xrdp on ubuntu 15.04 using these instructions: http://c-nergy.be/blog/?p=7984

When i try to rdp from my windows machine, it shows a grey window entitled "connection log" and it says "connecting to sesman ip x.x.x.x port 3350" but nothing else. (x.x.x.x = my ubuntu machine's ip addy)

It has an ok button... when i click on it, it just takes me back to the xrdp login dialog box.

Not sure what I'm doing wrong.

What I've tried In the login dialogue box, i have a few different options for "Module". The description above is what happens when I try the "sesman-Xvnc" option or the "sesman-any" option. When I try console, I get a different message:

it says:

  started connecting
  connecting to x.x.x.x 5900
  tcp connected
  security level is 0 (1=none, 2=standard)
  error - problem connecting.

Ideally, i want to connect so i have a desktop. I just tried command line to help debug the problem.

I'm not very good with linux but right now I"m just checking to see if the problem could be an unopened port. Just googling how to do that. But if you have any other tips I'd appreciate it.

EDIT 1

One artifact i just noticed that when i choose sesman-Xvnc (which is the default module) the connection log shows 127.0.0.1 instead of the IP Address of my ubuntu machine. Not sure if that means I missed some configuration somewhere. This is different from the behavior I see when I choose command line. Command line shows the right IP ...

EDIT 2

I selected the rdp-any module and it got further. I specify the right username / password and then i see this:

connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to the session manager please wait...
xrdp_mm_process_login_response: login successful for display
started connecting
connecting to 127.0.0.1 5910
error - problem connecting

On the ubuntu machine, i did "tail -f /var/log/syslog" and it writes out this record when the windows machine attempts to connect:

 Jul 19 10:31:54 myubuntubox systemd[1]: Started Session c8 of user testuser.
8
1

I assumed I could use just the default desktop in ubuntu. But i was wrong. I installed mate like so:

 sudo apt-get install mate-core mate-desktop-environment mate-notification-daemon

And then I told xrdp to use it like this:

 echo mate-session >~/.xsession 

And then i retried from my windows box and it works.

1
  • I have installed Ubuntu 16.04 LTS on Azure with resource manager. I have setup everything properly and I get a gray screen instead of any desktop :( Also tried what you have mentioned.
    – Sitz Blogz
    Mar 16 '17 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.