I recently had to re-install Ubuntu because it would not boot after some software changes. To install from a Live USB I had to change from UEFI mode to CSM. After reinstalling, the Grub menu does not show up and nothing boots unless I am in CSM mode and when it does, there is no Windows boot manager as an option and there are two new options called memtest86.

I ran the boot-repair tool in Ubuntu but nothing changed. When I boot the "Windows recovery" option in Grub it says that something went wrong with Windows and to load my Windows Recovery CD which I do not have.

From what I understand, I might have overwritten the Windows MBR in which case, since I don't have a CD I need to use lilo in Ubuntu to get it working again?

I have looked at all the questions here on this subject and that was my conclusion but I do not want to try it until some one could confirm. Thank you in advance.

  • Looking some more...could it be that I installed Ubuntu in CSM mode and Windows works in UEFI so I cannot access it? If that is the case then, when I change it to UEFI why does windwos not boot? – NULL Jul 18 '16 at 14:00
  • I found that I had in fact installed Ubuntu in CSM mode: when I run [ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD" it says Legacy boot on HDD. The problem is, my USB won't boot unless it is in CSM mode. Any ideas? – NULL Jul 18 '16 at 18:22

Eventually I found the answer: if you do not have one already, create a live CD or USB drive and plug it in your computer.

Keep your BIOS settings on UEFI boot, and when the Logo comes up, press the key that makes your computer show the boot order menu. For my Toshiba Satellite C55 it was F12. Changing the boot order in the BIOS would not let me boot my Live Media unless it was in CSM mode which is what we are trying to avoid.

Then select USB or CD depending on the media you used. Select install Ubuntu, and when given the option, select reinstall Ubuntu and keep files and folders. After the install reboot and cross your fingers...if Windows and Ubuntu are on the Grub Menu while in UEFI mode you got it!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.