1

I am running Ubuntu with i3 as my window manager. For some reason, some of my applications forget changes I make to their settings if I am not running the applications as root. For instance, if I try to add a shortcut to a Dropbox folder in the left hand side shortcut pane in the Thunar file manager, Thunar forgets the shortcut after having been closed. If I run Eye of Gnome (EOG) I am not even able to toggle the build in "image properties" pane on and off if am not running it as root. I suspect it is because the config files of the applications do not belong to my user, but I am not sure. And if it is the case, I do not know how to change it. If I for instance type ls -al ~/.config/Thunar into the terminal, I get the following message:

ls: cannot open directory '/home/USERNAME/.config/Thunar': Permission denied
3
  • 2
    How are you "running the applications as root"? If you are using plain sudo from the command line, then your diagnosis is likely correct - I suggest you edit your question to include the output of command ls -al ~/.config/Thunar/ – steeldriver Jul 18 '16 at 0:54
  • @Birdie Don't post images of text if you can just copy and paste the text into your post. – edwinksl Jul 18 '16 at 1:40
  • Sorry. I have tried to correct this now. – Birdie Jul 18 '16 at 7:40
1

You might likely solve with a

sudo chown USERNAME:USERNAME -R /home/USERNAME

where you substitute to USERNAME your user's name (the short one, without spaces and such that you can see at the beginning of the terminal line).

3
  • Thanks! This is the closest I have come to a solution. It seems that it almost works. But I still need to solve one more issue regarding this. It seems that I have to use this chown procedure every time new applications are installed, meaning that the default ownership settings are still wrong. Can this be changed? – Birdie Jul 18 '16 at 9:43
  • This is even weirder, because the applications do not start automatically when you install them, and so they do not create anything in your home. Is it not that you start them with sudo or as root right after you install them? Is fo, that is the problem. – dadexix86 Jul 18 '16 at 9:54
  • I think you are right. I believe I just solved the issue. It seems that typing the following solves my issue. I found it somewhere online. I believe I understand most of the syntax, but hopefully this wont make me run into security issues. (Sorry for the bad layout - I tried my best!) ME=whoami, chown $ME:$ME -R /home/$ME/, chmod g+s /home/$ME/, setfacl -d -m g::rwx /home/$ME/, setfacl -d -m o::rx /home/$ME/. – Birdie Jul 18 '16 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.