4

I have been trying to install Theano on my Ubuntu partition on a Dell Vostro laptop. It requires Cuda for using the gpu.

But I seem to have lost the Nvidia drivers somehow.

lspci -vnn | grep -i VGA 

gives this

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) (prog-if 00 [VGA controller])

so the Nvidia driver isn't listed. Also it is no longer listed in "Additional Drivers"

sudo apt-get install nvidia-current

gives

Reading package lists... Done
Building dependency tree       
Reading state information... Done
nvidia-current is already the newest version.

So, what am I missing?

Update:

lspci -k | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
  Subsystem: Dell Device 044f
  Kernel driver in use: i915

Update:

When I rebooted I got a black screen so I guess the drivers were lost. From the boot command line I did manage some reinstall of dirvers following this page. This did enable me to get back in the nvidia drivers weren't appearing in additional drivers.

Although I did try I tried in vain to resinstall the binary drivers. I decided I had to do a complete reinstall of my Ubuntu partition.

Having done this the nvidia drivers are now appearing in additional drivers.

drivers

What does it mean that it is using the X.Org server? Does that mean it is not using the Nvidia GPU?

Update: I tried

sudo apt-get update sudo apt-get purge nvidia-current nvidia-updates

Got "Unable to locate package nvidia-updates" so did

sudo apt-get purge nvidia-current sudo apt-get install nvidia-340 libcuda1-340

But when I reboot I just get a black screen.

I've learned that if you do ctrl+alt+f1 at this point you get a terminal screen.

I managed to get back to the gui by these commands from here.

sudo apt-get update

sudo apt-get dist-upgrade

sudo apt-get install build-essential

sudo apt-get install linux-source

sudo apt-get install linux-headers-generic

sudo apt-get dist-upgrade

sudo reboot

sudo apt-get install nvidia-current-updates

sudo nvidia-xconfig

sudo reboot

But they remove nvidia-340 and libcuda1-340.

I tried again with

sudo apt-get purge nvidia-current

sudo apt-get install nvidia-340 libcuda1-340

and

sudo nvidia-xconfig

sudo service lightdm restart

But this remains on the black screen. So I am back to square one.

Update 2016.07-30:

sudo apt-get update

sudo apt-get purge nvidia*

sudo apt-get install libgles1-mesa libgles2-mesa libosmesa6 libva-drm1 libva-egl1 libva-glx1 libva-tpi1 libva-wayland1 libva-x11-1 vainfo libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa libxatracker2 libvdpau-va-gl1 libdrm-intel1 libdrm2 libva1 va-driver-all i965-va-driver intel-gpu-tools

sudo apt-get dist-upgrade

I ran these commands, though without va-driver-all as I got this error, E: Unable to locate package va-driver-all

On reboot the graphics came up ok and additional drivers showed using NVIDIA binary driver 340.96 (proprietary tested)

So that seems to have worked, thanks. Though there are still problems with cuda, but have asked another question for that here.

  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. – Pilot6 Jul 17 '16 at 18:30
  • Are you sure you have an Nvidia adapter and it is not disabled in BIOS? – Pilot6 Jul 17 '16 at 18:55
  • I did have I think, Nvidia driver appeared in Additional Drivers. How do I tell if disabled in BIOS? – PerceptualRobotics Jul 17 '16 at 19:05
  • Get into BIOS and look there. You can run lspci and see there too. If it is not there, then there is no Nvidia. – Pilot6 Jul 17 '16 at 19:06
  • Well, I booted into windows and there it says NVIDIA GeForce GT 330M. – PerceptualRobotics Jul 17 '16 at 19:36
2

According to www.geforce.com/drivers You should be using the following nvidia driver for your specific card. Run the following commands to install:

sudo apt-get update
sudo apt-get purge nvidia-current nvidia-current-updates
sudo apt-get install --reinstall nvidia-340 libcuda1-340

To explain about the xorg driver: because you installed nvidia-current instead of nvidia-340 and because nvidia-340 wasn't installed, your system was using nouveau instead of the proprietary drivers.

The names are confusing (nvidia-current) but nvidia-340 is the one you need and you will receive current updates automatically for your nvidia driver along with the rest of your system software.

Reboot for the changes to take effect.

Additionally, these are the binary drivers so there is no need to download anything from the nvidia website, it's already installed.


UPDATE

After doing the above and after you reboot:

Typically, you don't always have to run nvidia-xconfig but sometimes you do so sign into a tty (Press CTRL + ALT + F2 and sign in with your user name and password) and then run the following command:

sudo nvidia-xconfig
sudo service lightdm restart

If that doesn't work, reboot.

If that still doesn't work, run the command dmesg and look for anything relevant to the problem like a failed module or xorg.

Please post any errors, thanks.


UPDATE-2

First go into your BIOS settings and make sure the Nvidia card is enabled. Power on the laptop and quickly press F2 repeatedly until the BIOS settings screen opens.

If it is enabled, boot into ubuntu and run the following commands:

sudo apt-get update
sudo apt-get purge nvidia*
sudo apt-get install libgles1-mesa libgles2-mesa libosmesa6 libva-drm1 libva-egl1 libva-glx1 libva-tpi1 libva-wayland1 libva-x11-1 vainfo libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa libxatracker2 libvdpau-va-gl1 libdrm-intel1 libdrm2 libva1 va-driver-all i965-va-driver intel-gpu-tools
sudo apt-get install --install-recommends nvidia-340
sudo apt-get dist-upgrade

Reboot.

If it starts in low graphics mode, press CTRL + ALT + F2 and sign in with your user name and password.

Then, execute the following commands:

sudo service lightdm stop
sudo nvidia-xconfig
sudo service lightdm start

If that doesn't work, run the following command and please post the output:

sudo modprobe nvidia

UPDATE 3

sudo apt-get update

sudo apt-get dist-upgrade

sudo apt-get install --reinstall build-essential

sudo apt-get install --reinstall linux-source

sudo apt-get install --reinstall linux-headers-generic

sudo apt-get dist-upgrade

sudo reboot

sudo apt-get install nvidia-340-updates

sudo nvidia-xconfig

sudo reboot
  • I installed cuda 7.5, and have nvidia-340 and libcuda1-340 installed. Now when I reboot I get a message "The system is running in low graphics mode" and now I can't get back into the gui. – PerceptualRobotics Jul 20 '16 at 17:04
  • @PerceptualRobotics Thank you for the info. I have updated the answer. – mchid Jul 21 '16 at 17:47
  • I am trying your instructions again. Btw, "sudo apt-get purge nvidia-current nvidia-updates" gives this "E: Unable to locate package nvidia-updates" – PerceptualRobotics Jul 22 '16 at 9:13
  • Thanks for your update. I have updated with latest attemtps. – PerceptualRobotics Jul 22 '16 at 9:53
  • 1
    @PerceptualRobotics Okay, then run those commands with nvidia-340-updates instead of nvidia-nvidia-current-updates. Nvidia-current-updates installs an ancient version 304 that does not drive your card. – mchid Aug 2 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.