11

I have a minidlna server running in my home and everything worked fine when i updated to ubuntu 16.04 my vlc stopped finding my server. I ran VLC via terminal and got this error when clicking on the UPnP tab. :

[00007fdb784db098] upnp services discovery: Initializing libupnp on '(null)' interface
[00007fdb784db098] upnp services discovery error: Initialization failed: UPNP_E_SOCKET_BIND
[00007fdb784db098] core services discovery error: no suitable services discovery module

Does someone have any idea how to fix this?

My TV and phone can still find my server.

15

Disabling ipv6 worked for me.

Solution from here :

echo 1 | sudo tee /proc/sys/net/ipv6/conf/all/disable_ipv6
| improve this answer | |
  • Thanks man! It's almost an year that I have this problem and never found the strength to google for it until now! – Avio Oct 13 '19 at 14:56
7

I found the answer.

You can download a new version of libupnp here

And install it :

cd Downloads
sudo dpkg -i libupnp6_1.6.19+git20160116-1_amd64.deb
| improve this answer | |
  • 3
    Doing so allowed vlc to display dlna host, but that's all. After that I see in the vlc console the following message: total jobs = 100, too many jobs – Sergey P. aka azure Dec 18 '16 at 14:12
  • Using this lib I was able to browse a local upnp network from VLC 2. Ubuntu 16.04 LTS. It doesn't work from VLC 3 but you can open an URL from a video that you browsed from VLC2 (RC display information copy URL). – Rudy Vissers Aug 3 '19 at 19:09
0

In my case firewalld was blocking the traffic on the port 1900 tcp/upd. I enabled it and it worked:

firewall-cmd --permanent --zone=public --add-port=1900/tcp
firewall-cmd --permanent --zone=public --add-port=1900/udp
firewall-cmd --reload
firewall-cmd --permanent --zone=home --add-port=1900/tcp
firewall-cmd --permanent --zone=home --add-port=1900/udp
firewall-cmd --reload

Adapt the code to your zone.

Reference: http://www.vassox.com/infrastructure/networking/opening-a-port-with-firewalld/

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.