0

So I must've power off my laptop the hard way yesterday when I was in a rush. After trying to boot it today, it popped up with Ash (or whatever it is called - the prompt was: initramfs$ or something like it). I ran fsck, pushed down the 'y' key, and waited.

It soon booted up to gdm, but it's now stuck in a login loop.

I did ctrl+alt+F3 and typed startx, but unfortunately it comes back after a second with

xauth: file (...)/.Xauthority does not exist
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Couldn't get a file descriptor referring to the console

I tried to purge and reinstall gdm3 package, also tried to reconfigure it - no luck. Stuck still.

I'm running Ubuntu Gnome 16.04.

1 Answer 1

0

I can get to the GUI bu making a new user with

sudo adduser ...
sudo usermod -aG sudo ...

But that is really suboptimal, since the older user had a highly custom configuration, and it is a real pain in the you-know-what to reconfigure the new one from scratch now.


Turns out that some files inside ~/.config and ~/.dconf were corrupted. Trying to access them spew out input/output errors. After renaming these directories every profile setting is gone, but gdm isn't looping at least. They are recreated with default data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.