I recently got a new Dell XPS 15 9550, and I followed the instructions of the OP in this thread https://ubuntuforums.org/showthread.php?t=2317843 to set it up to dual boot Windows 10 and Ubuntu 16.04. (Basically just disable safe boot and fast boot, change from RAID to AHCI in BIOS, then install Ubuntu and make sure graphics and other drivers work). Everything works pretty well immediately after installation.

I want to disable the "TapAndDragGesture" which is enabled by default in synaptics. But when I use synclient to do so: synclient TapAndDragGesture=0 the gesture does not completely go away. The behavior is that now, if I double tap, it will drag for a brief period of time (about half a second, as opposed to dragging for however long I keep my finger on the touchpad).

This is still very irritating as the amount of time it drags is still enough for me to accidentally move tabs around (as I tend to do when quickly tapping to switch tabs).

Has anyone experienced this issue or something similar? And does anyone know how to fix it? Thanks in advance.

I use the synclient MaxTapMove=0 to solve the problem. Although I am really not sure it is the right solution.

  • Doesn't seem to work for me though. The behavior still persists. – xji Jan 26 at 8:38
  • 2
    A combination of: synclient TapAndDragGesture=0 synclient MaxTapMove=0 solved the problem for me – Miao ZhiCheng Mar 13 at 12:21
up vote 3 down vote accepted

I was able to resolve this issue by installing and using libinput instead of synaptics for my input driver.

This post describes the installation process very simply for 15.04+ (I am on 16.04).

After following these steps, you can verify that your touchpad uses libinput: in the terminal type xinput list to get the device id of your touchpad, then:

xinput list-props <device_id>

Most of the properties in the list should have "libinput" as part of the name.

Finally, to disable the "Tap and Drag gesture", simply edit the file /usr/share/X11/xorg.conf.d/90-libinput.conf. Find the section for the touchpad and disable the tapping drag option:

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "TappingDrag" "false"
EndSection

There are many other useful options that can be changed or tweaked, which is well documented here

Once the options are set, save the file, log out, log in, and enjoy!

  • Now the file seems to be named 40-libinput.conf instead of 90 – xji Jan 27 at 17:57
  • Did you get an error message when running ./autogen.sh --prefix=/usr in the "build and install" phase of the installation process of libinput ? It tells me bash: ./autogen.sh: No such file or directory, I wonder whether other users ran into this problem and if they found a fix ... – Olivier Bégassat May 9 at 17:43
  • @OlivierBégassat, I installed libinput through apt, I did not build it from source, so I am not sure how to resolve your issue. I'm also now using Ubuntu 17.10 which I believe has libinput installed by default. – Daniel Hathcock May 9 at 18:15
  • I see, using something along the lines of sudo apt-get install libinput I presume ? Do you remember the command, this one doesn't work for me (I just tried it). – Olivier Bégassat May 9 at 18:37
  • This answer describes how. It looks like just sudo apt install xserver-xorg-input-libinput is sufficient. – Daniel Hathcock May 9 at 19:11

On Wayland (Ubuntu 17.10) I disabled tap-and-drag gesture with

gsettings set org.gnome.desktop.peripherals.touchpad tap-and-drag false

And logged out and back in.

  • Worked really well for me on a Macbook Pro 15" 2015, Ubuntu 17.10.1 (: Good stuff. – knut Apr 14 at 14:43
  • This also worked for me. Does anyone know what the difference is between disabling in gsettings vs. in the libinput conf? – bennlich Aug 13 at 4:13
  • libinput works with X11, gsettings with Wayland. – Mitar Aug 13 at 6:14

I have exactly the same frustration, but just from single tapping in order to focus something, then releasing and dragging the pointer away which causes the newly focused tab (for example) to be dragged across. Super annoying. I have a solution which seems to be more a work-around, but stops this from happening.

xinput set-prop [touchpad ID] "Synaptics Gestures" 0

(Find out the ID of your touchpad by running xinput without passing any arguments.)

I can still see the tabs/windows being attempted to drag, but then stop immediately and "snap back". Kind of a fluke perhaps, but it works.

As far as I know that option is only about tap-and-drag:

Option "TapAndDragGesture" "boolean"
        Switch on/off the tap-and-drag gesture. This gesture is an alternative way of dragging. It is performed by tapping (touching and releasing the finger), then touching again and moving the finger on the touchpad. The gesture is enabled by default and can be disabled by setting the TapAndDragGesture option to false. Property: "Synaptics Gestures"

Synaptics Gestures
        8 bit (BOOL), 1 value, tap-and-drag.

Source: synaptics(4) - ftp://www.x.org/pub/X11R7.5/doc/man/man4/synaptics.4.html

  • This seems to do the same as what the OP described: The dragging continues for about half a second before stopping, which makes it even worse... – xji Jan 27 at 17:40

Easiest solution for those using Ubuntu 16.04!

To list all actions your Synaptics Touchpad has:

synclient

To change an option:

synclient PARAMETER=#

EXAMPLE: Disabling Tap and Drag:

synclient TapAndDragGesture=0

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.