2

I am running ubuntu 16.04, and when I try to install a program using apt-get install (really any program, but take git-all for example), I get the following error:

start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

the full error stack is below:

sudo apt-get install git-all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
git-all is already the newest version (1:2.7.4-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 283 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up runit (2.1.2-3ubuntu1) ...
start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: error processing package runit (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of git-daemon-run:
 git-daemon-run depends on runit; however:
  Package runit is not configured yet.

dpkg: error processing package git-daemon-run (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 runit
 git-daemon-run
E: Sub-process /usr/bin/dpkg returned an error code (1)

I realize this error has been posted around the internet for over a year now, and I know that it is caused by the fact that upstart was replaced by systemd, and but not all programs have been switched to using systemd. But none of the fixes work for me.

There is this post, which has been flagged as potentially dangerous and has caused many people to be unable to boot their system: "nesono.com/node/368"

Then there is this post: "vivid - failed to connect to upstart: connection refused". The "recommended fix" is to switch all systems to systemd manually according to this link: "https://wiki.ubuntu.com/SystemdForUpstartUsers". But the linked page does not actually show how to switch everything to systemd. And the "quick fix" option (running sudo apt-get install upstart-sysv to switch back to upstart), which appears to actually be the one recommended and implemented by most people experiencing this problem, does not work for me either because again, apt-get gives me an upstart error.

"https://www.nesono.com/node/368" Also suggests going into GRUB2 and using the bootloader to start the system using upstart. However, this is not an option for me in the bootloader, which leads me to believe I evidently do not have upstart on my computer (yet again another failed fix).

There is also a similar issue posted here that appears to be unresolved (no accepted answer): "askubuntu.com/questions/728581"

Please help!

2
  • Any help would be greatly appreciated! I would have posted more links to other failed solutions and bug reports, but I wasn't allowed to. This seems to be a pretty common problem without a good solution for over a year.
    – Paul
    Jul 19, 2016 at 17:16
  • is there any way that I can make the question clearer or make it easier to answer?
    – Paul
    Jul 25, 2016 at 19:24

0

Browse other questions tagged or ask your own question.