Trying to run videos in Hulu, and keep getting DRM errors even though I've cleaned the licenses, etc. It's telling me I have to have HAL installed; I've tried doing so using apt-get repeatedly, and it just won't do it. Can anyone give me some fairly clear instructions on how to get HAL installed for Firefox on 16.04LTS? I do realize it's being replaced, but anyone got a clue as to how to get my Hulu working in this instance?

  • On my machine, I simply typed sudo apt-get hal, and it worked. Could you edit your post to include any errors you're getting? Also, if apt-get is giving you issues, sometimes sudo dpkg --configure -a can help. – TSJNachos117 Jul 16 '16 at 20:05
  • i have no experience with the DRM-troubles but for Linux Mint (a Ubuntu derivative) this seems to be a good tutorial: community.linuxmint.com/tutorial/view/2028 – DJCrashdummy Jul 16 '16 at 20:05
  • Thanks, guys, but that's not getting it. I need to know the apt line for the hal package, apparently, to add it to the personal repository. I can't find that anywhere. – Firetree Actual Jul 16 '16 at 20:24
  • I asked a similar question here a while ago. – user364819 Jul 16 '16 at 21:11
  • Thank you...yup, similar issue, still no way around it. This is a prevalent issue in Hulu, Amazon, and Netflix. Amazon just tells me to stop bitching and install Chrome (??!!). OK...I did that on 14.10LTS and that solved it for Amazon...but even Chrome is a bitch to install on 16.04LTS; I've not been able to get that to work, either. I asked Hulu to dig up an answer as well, letting them know I'll have to cancel if it won't work. – Firetree Actual Jul 16 '16 at 21:24

FIX for Hulu using Firefox v49.0 on Ubuntu 16.04 LTS (64-bit):

(For Netflix, see further down below.)

  1. Install Flash 11.2 (use the APT download method via Adobe).
  2. Install Zombie HAL. Restart your browser.
  3. In Firefox go to Edit -> Preferences.
  4. Click on the Content option.
  5. Ensure that "Play DRM content" is enabled.

Another workaround is to use Google's Chrome browser.

Netflix: After you do the steps above, you can also stream Netflix on Ubuntu using Firefox, but Netflix is annoying because they don't like supporting Firefox on Linux and because they use Microsoft's Silverlight technology (which is another proprietary competitor to Flash). A workaround is to do the following:

  1. Install Pipelight for Ubuntu, then restart Firefox.

  2. Install the "User Agent Overrider" add-on (I'm using version 0.4.1 by muzuiget). You do this by clicking on Tools -> Add-ons and searching for it there in Firefox.

  3. Once you have the User-Agent add-on installed, you click on its button and you can choose one of the Windows identities. This spoofs to Netflix that you are on a Windows computer when you are actually using Ubuntu. Though, when I'm done viewing Netflix, I'll disable this spoofing feature by clicking on the "Default" identity as I want websites to know I use Linux. This way, I help to encourage more companies to support us natively. (Or you can leave the spoofing feature on if you're helping people to convert to Linux. So it seems to them that there are no "weird bugs" with using Linux.)

Oh, also, if Netflix throws you to an error page saying that you need Silverlight installed, you need to make sure that you enable the fake User-Agent spoofing BEFORE you visit Netflix not once you arrived at their site.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.