1

I have an Ubuntu 14.04 machine that i use as a fileserver and i have installed Ubuntu 14.04 on my laptop as the only OS. lately i have been having issues where the mounted drive on my server seems to be dropping kinda randomly so i find myself remounting the drive. i found that when i sshed into my server machine from my laptop (sudo ssh name@x.x.x.x), once i close the connection it seems to lose the mount so whenever i click the bookmark ubuntu responds with..

"oops! Unhandled error message: Invalid argument". 

After checking the server the files appear to be there and working just fine. i used to have WIN10 on this laptop and was able to reach files/add/delete with no problem, but i feel like ever since i nixed windows for ubuntu I've been having an issue connecting to the same files. I've had the folders configured with samba on the server for years with no issue until now.

so now for the question: when i had WIN10 i connected via putty to the server to do my configuring. now that i am running ubuntu 14.04 on the laptop and use "ssh name@x.x.x.x" to connect is there a different way that i am supposed to mount the drives? I've been mounting them for the longest time using "sudo mount /dev/sdb1 /home/me/sharedfiles" and it had always worked just fine. It seems like when i mount the drive from my laptop command line via ssh it drops shortly after closing terminal, but when i do it on the server itself it stays mounted...at least its been mounted for most of today so far without a problem.

/etc/fstab
/dev/sdb1       /home/joey/sharedfiles          ext4    defaults        0       2  
/dev/sda1       /home/joey/more_sharedfiles     ext4    defaults        0       2
0

A mounted file system should stay mounted.

If you want to keep your mounted fs after a reboot/power failure, etc, you can make an entry for the fs in /etc/fstab.

https://help.ubuntu.com/community/Fstab

regards

  • I do have it in /etc/fstab. After reboot it doesn't stay tho. Tried with uuid and /dev/sdb1 but on reboot I have to mount again, but it usually stays there until. When I use my laptop and ssh into server seems to be where the issue is. It's like it doesn't see the mount when it is clearly mounted and usable from the server itself. – cyrussrivera Jul 16 '16 at 19:14
  • Hm please post your /etc/fstab, it could be set to "noauto" Option or something else. You can check if the disk is mounted in /etc/mtab btw. – Lord_PedantenStein Jul 16 '16 at 19:20
  • sorry i just started using this forum and haven't quiet got the hang of it yet. – cyrussrivera Jul 16 '16 at 19:41
  • i updated to show /etc/fstab – cyrussrivera Jul 16 '16 at 19:48
  • right now i am currently watching a movie from my server using the share, but when i ssh into the server from my laptop it shows "oops! Unhandled error message: Invalid argument". – cyrussrivera Jul 16 '16 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.