1

I recently upgraded to ubuntu 16.04 and my processor keeps running. I checked top and there's a kworker always running. I checked dmesg errors like the following keep be logged:

[329479.460021] nand: timeout while waiting for chip to become ready
[329479.860009] nand: timeout while waiting for chip to become ready
[329480.260009] nand: No NAND device found
[329480.260023] r852: detected SmartMedia readonly card in slot
[329480.524457] r592: IRQ: card added
[329480.524466] r592: IRQ: DMA error
[329480.604394] r592: IRQ: card added
[329480.604399] r592: IRQ: DMA error
...(stack trace)

Any idea of how I can trouble shoot this? I can't decipher the posts on launchpad.

edit: It looks like here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1530187 So is there no fix?

1

I experienced this same problem too. It seems this bug is related to Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter. A possible workaround is blacklisting the module if you don't use the Card Reader a lot.

Create a file in /etc/modprobe.d/ with name blacklist-r592.conf and put this line in that file

blacklist r592

then restart the PC. The error should go away.

Alternatively, you can also use this two line instead (change the filename accordingly if you want) as suggested in this bug report comment

options r592 enable_dma=0
options r852 r852_enable_dma=0

But this is not tested by me.

0

When I check dmesg, I still get these errors, but kworker isn't going crazy.

The problem for me was I has installed 64bit ubuntu instead of 32bit ubuntu.

oye vey!

1
  • I don't think this is a solution. Can happen even when the architecture is correct – Anwar Dec 11 '16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.