2

The Problem

  • My WiFi network disconnects itself randomly and start asking for password.
  • The password is already stored,I just have to click on connect.
  • When I click on connect ,it remains connected for some time then again disconnects and sometimes it even does not connects.
  • The speed while being connected is very low and torrents are not downloading.
  • When sometimes I connect to WiFi I got System encountered a error dialogue box

What did I do

  • I go to Edit connections and make sure that All users can connect is ticked.

  • I also deleted config file of connection from /etc/NetworkManager/system-conncections

Still I can't connect to WiFi sometimes and it disconnects automatically if get connected after some time. So what should I do?

After googling I found that this problem has been encountered in earlier versions , I am using Ubuntu 16.04 so if there is a permanent solution which can help everyone that will be the best.

P.S.- I have already tried these links My wireless/WiFi connection does not work. What information is needed to diagnose the issue? , WiFi repeatedly asks for password (Ubuntu 12.10 fresh) and http://www.askubuntu.com/questions/285287/wifi-keeps-asking-for-password-ubuntu-12-10 . Also the WiFi network works fine with my mobile.If more information is needed than let me know and how I can find it.

Also after seeing this I have a hardware detection problem, what logs do I need to look into? i found that no card was soft or hard blocked and rest info I found after using commands are on http://paste.ubuntu.com/19615988/

Output of lspci -knn | grep Net -A2

02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 130 [8086:0896] (rev 34)
Subsystem: Intel Corporation Centrino Wireless-N 130 BGN [8086:5005] Kernel driver in use: iwlwifi

New Update: I can't to my WiFi network, I have to use USB tethering in mobile to use internet on my laptop.

  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Jul 16 '16 at 11:35
  • 1
    Run sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=1", reboot and test again. – Pilot6 Jul 18 '16 at 11:45
  • @Pilot6 thanks it worked. Can you write a answer so that I can accept it and it will also help others and please mention what does this command did? – bha159 Jul 18 '16 at 11:52
  • There are a few adapters that do not support this protocol. This solution is applicable to all of them. I could not find an wxact duplicate, so I wrote an answer. – Pilot6 Jul 18 '16 at 11:55
3

These adapters do not support 802.11n protocol well (at least on linux), but iwlwifi driver tries to use it. You can disable this protocol by running in terminal

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=1"

This will be applied after a reboot.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.