3

I'm running 16.04. I have 6 DKMS drivers installed and running fine.

However, two communications device drivers (rtl88212au and rtl8814au) build incorrectly when the kernel gets updated during a Ubuntu software update. As such, these two drivers won't load. If I do a modinfo on either of these drivers after a Ubuntu software update, the vermagic value shows that it's for the previous version of the kernel, when it should show the current/new version of the kernel.

I do have secure boot disabled, and my other 4 DKMS drivers work fine. Just these two don't build correctly.

I have to do a dkms remove, and then these same drivers dkms build and dkms install just fine when done manually.

Here are the two dkms.conf files:

PACKAGE_NAME="rtl8812au"
PACKAGE_VERSION="4.3.8.12175.20140902+dfsg"
BUILT_MODULE_NAME[0]="8812au"
MAKE[0]="'make' all"
DEST_MODULE_LOCATION[0]="/updates/dkms"
AUTOINSTALL="YES"

PACKAGE_NAME="rtl8814au"
PACKAGE_VERSION="4.3.17.13720.20150622_beta_led"
MAKE[0]="'make' all"
BUILT_MODULE_NAME[0]="8814au"
DEST_MODULE_LOCATION[0]="/updates/dkms"
AUTOINSTALL="YES"
REMAKE_INITRD="YES"

Any ideas on where to start looking for trouble?

Cheers, Al

  • Disable Secure Boot in BIOS. – Pilot6 Jul 16 '16 at 15:30
  • Secure Boot is disabled in the BIOS. Otherwise, none of the unsigned DKMS drivers would load. I'm just having a problem with these 2 (out of 6) drivers building/installing correctly after a software update that contains a new kernel (when DKMS is used). Cheers, Al – heynnema Jul 16 '16 at 15:36
  • What is the "new kernel"? What are error logs? – Pilot6 Jul 16 '16 at 15:44
  • The "new kernel" is whatever Software Update decides to update to. The error can be seen if I try to manually load a bad driver using modprobe, and it errors with something like "format error" or "version error"... I forget the exact message. It's the reason that they don't load at boot time. Are you experienced in DKMS? Cheers, Al – heynnema Jul 16 '16 at 19:55
5

Edit these dkms.conf files:

for the rtl8812au...

sudo -H gedit /usr/src/rtl8812au-4.3.8.12175.20140902+dfsg/dkms.conf
sudo -H gedit /var/lib/dkms/rtl8812au/4.3.8.12175.20140902+dfsg/build/dkms.conf

for the rtl8814au...

sudo -H gedit /usr/src/rtl8814au-4.3.17.13720.20150622_beta_led/dkms.conf
sudo -H gedit /var/lib/dkms/rtl8814au/4.3.17.13720.20150622_beta_led/build/dkms.conf

and replace:

MAKE="'make' all" 

with this line:

MAKE[0]="'make' all KVER=${kernelver}"
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.