I am trying to get my Canon LBP2900 printer to work on Ubuntu 11.10 64 bit.

What I have done is try to follow the steps on https://help.ubuntu.com/community/CanonCaptDrv190

So I downloaded the version 2.3 driver and tried to convert the rpm files to debian and installed them

sudo alien cndrvcups-capt-2.30-1.x86_64.rpm cndrvcups-common-2.30-1.x86_64.rpm
sudo dpkg -i cndrvcups-capt-2.30-1.x86_64.deb cndrvcups-common-2.30-1.x86_64.deb

restarted cups and try to install the printer with lpadmin:

sudo service cups restart
sudo /usr/sbin/lpadmin -p LBP2900 -m /usr/share/cups/model/CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59787 -E

What I noticed however that on the step with lpadmin it goes wrong with the error:

lpadmin: Bad device-uri scheme "ccp"

After trying to trace what has gone wrong, I think I nailed it to the fact that dpkg installed a file /usr/lib64/cups/backend/ccp instead of /usr/lib/cups/backend/ccp

Checking the original rpm with archive manager shows indeed that /usr/lib and /usr/lib64 are used, with the backend/cpp file only installed in lib64. As I understand correctly, Ubuntu 11.10 uses /usr/lib32 and /usr/lib instead so the files are installed in the wrong place.

Is there an automated method of converting the rpm/deb files with the wrong lib structure to one with the right lib structure for ubuntu 11.10? Or am I completely on the wrong track for getting my printer installed?

  • can you confirm in your question whether the bug report for oneiric at the bottom of that link is applicable to your printer type?
    – fossfreedom
    Nov 18, 2011 at 20:22
  • @fossfreedom I did the modprobe to get that module to load, that part is working. The problem is really with the wrong installation directories I think...
    – Peter Smit
    Nov 20, 2011 at 15:48
  • I cant answer about "an automated method" - I dont think it is possible. However, if the code was expecting stuff in one folder then you can symbolic link from one folder to another i.e ln -s target linkname e.g. ln -s /usr/lib64/cups/backend/ccp /usr/lib/cups/backend/ccp
    – fossfreedom
    Nov 21, 2011 at 17:02
  • Same question asked (still unanswered), for Karmic 64bit, at: ubuntuforums.org/showpost.php?p=8434976
    – david6
    Nov 23, 2011 at 0:25
  • Does your ccpd file have the same content as this (example): pastebin.com/bsQ95E3z AND does the section "DevicePath /dev/usb/lp0" match your device location?
    – david6
    Nov 23, 2011 at 0:33

2 Answers 2


What I noticed however that on the step with lpadmin it goes wrong with the error: lpadmin: Bad device-uri scheme "ccp"

It is because you didn't generated the scripts associated with the rpm files.......


sudo alien cndrvcups-capt-2.30-1.x86_64.rpm cndrvcups-common-2.30-1.x86_64.rpm --scripts


sudo alien *.rpm --scripts

instead of

sudo alien *.rpm

You can solve this error

lpadmin: Bad device-uri scheme "ccp"

All the best from RJK

  • @PeterSmit : If this problemis solved... you can mark it as solved :) It may help others too
    – rjkrocks
    Apr 19, 2012 at 12:33

I do not own this particular model from Canon but i never find any trouble when installing a new printer on my system, also Canon declares this driver as working under all the latest versions of Ubuntu and many other GNU/linux distribution.


Here you can download driver for both 32 and 64 bit operative systems, also there are the source included in the package so you can build your own driver from the scratch.

Do not use the rpm as first resource especially on a deb based system.

to find out what libreries are used by a specific executable run this command

ldd [path to exec]

Sometimes there are scripts available to start the program and they are not executables, to find out where the real executable is located you have no choice other than investigate the source of the script.

For example to know which libraries are used by java you can use ldd combined with which that is a command that gives you the full path of an keyword command ( only which works for both scripts and exec, ldd need an exec ):

ldd $(which java)

I suggest to completely remove those installed packages and compile from the source, if you can't remove those packages safely try to do something with ldd and verify that all the required libraries are linked to your executables, you can also run this command sudo apt-get install -f to try to fix some missing packages.

EDIT: i almost forgot this, to update all the linking between the libraries and the executable you have to run sudo ldconfig and this is useful after you have installed new libraries.

Apparently there are good links with this search http://www.google.com/search?q=compile+cndrvcups-common and some good ppa too.

  • Could you indicate: 1) Where Canon declares the driver to be working, and 2) Where Canon has published a 64-bit deb file of the CAPT driver. The problem is not that libraries are not linked well, but that the cpp protocol file is installed on the wrong location. The ppa you indicated in your search is not working for Oneiric.
    – Peter Smit
    Nov 23, 2011 at 3:29
  • 1) at the page where you can find the download link for your package 2) I didn't say that, i didn't mention the deb, you can compile from the source if you wish or use a ppa ( where you can also downloade the deb "manually" if you like ) 3) launchpad.net/~michael-gruz/+archive/… or google.com/#q=ppa+canon+capt if you wish :)
    – Micro
    Nov 23, 2011 at 3:38
  • 1) canon.co.uk/Support/Consumer_Products/products/printers/Laser/… says nothing about whether the driver is working for the latest Ubuntu version 2) if you say driver for 32bit 64bit or source package, but not the rpm, than you imply there is a 64bit deb. 3) As I indicated now, that PPA is not working
    – Peter Smit
    Nov 23, 2011 at 3:43
  • i think that the real problem is your installation, installing an rpm is one of the best way to corrupt your system, i can't think that the ppa it's not really working simply because it does and i checked.
    – Micro
    Nov 23, 2011 at 3:47
  • I didn't install an rpm, but an with alien to deb converted rpm. Why if the ppa is working is putted in this guide: help.ubuntu.com/community/CanonCaptDrv190 different instructions for 11.10? I will later today check the ppa again, and see what went wrong there for me.
    – Peter Smit
    Nov 23, 2011 at 3:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.