0

I'm using Kubuntu 16.04 on a laptop, and I face a strange problem. I have an internal WiFi card as well as a USB WiFi dongle. I prefer to connect to WiFi using the dongle because the internal WiFi is unreliable and gives spotty connection. However, when I try to connect to eduroam (WPA2-PEAP) using the USB WiFi, the network-manager disconnects wifi altogether (WiFi is on, but whole network-manager screen is blank) as soon as it first connects to the WiFi (e.g. opening homepage / page refresh / dropbox connecting etc). However, it doesn't happen with the internal WiFi card. I have to use sudo service network-manager restart for making all WiFi networks visible again.

  • Is the driver for the internal device blacklisted or is it loading and possibly conflicting? – chili555 Jul 15 '16 at 17:56
  • @chili555 How do I find it out? – taninamdar Jul 15 '16 at 18:14
  • Run the terminal command: lspci -nnk | grep 0280 -A2 Does it show a kernel driver in use? Is it loaded? lsmod If it is, I'll suggest you blacklist it to see if the performance improves. – chili555 Jul 15 '16 at 18:46
  • 08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01) DeviceName: Realtek RTL8188EE 802.11b/g/n 1x1Wi-Fi Adapter Subsystem: Hewlett-Packard Company RTL8188EE Wireless Network Adapter [103c:804b] – taninamdar Jul 15 '16 at 19:17
  • And is some driver loaded? lsmod | grep rtl – chili555 Jul 15 '16 at 19:55
0

I suggest that you unload the driver for the internal device:

sudo modprobe -r rtl8188ee

And blacklist it:

sudo -i
echo "blacklist rtl8188ee"  >>  /etc/modprobe.d/blacklist.conf
exit

Any improvement? It may take a reboot.

  • I see, I'll look into that. But if I understand correctly, it will improve the performance of the internal wifi card, right? How do I solve the original problem? – taninamdar Jul 15 '16 at 20:36
  • No. It will disable the internal in order to get the USB to work correctly. Don't worry, if need be, it is easily reversible. – chili555 Jul 15 '16 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.