9

16.04 Xenial

APT automatic update check: enabled

APT automatic update download & install: disabled

No cron jobs listed below,

$ for user in $(cut -f1 -d: /etc/passwd); do sudo crontab -u $user -l; done

The system suddenly topped by heavy load pertaining to both CPU and Network IO from the aroused unattended-upgrade for several minutes.

Why could it happen when automatic update download & install were totally disabled?

2
  • 2
    A better question is why does it hammer the CPU. Disabling it is just a work-around for a bigger issue. I'm getting this on 18.04 VM this morning. Running 100% for about 10 mins when booted. Now at about 25% for last 20 mins. Reminds me of Windows updates. – bshea Sep 22 '19 at 12:12
  • @bshea Its actually worse than Windows updates. – Rolf Mar 1 at 10:02
16

The functionality on unattended-upgrades is automatically enabled after the installation of 16.04 Xenial Server. I mistakenly didn't really disable it so observed the unexpected behaviors above. Method Two here I had followed is unlikely effective.

To properly disable the automatic updates, we need change the configuation on /etc/apt/apt.conf.d/20auto-upgrades from:

APT::Periodic::Unattended-Upgrade "1";

to:

APT::Periodic::Unattended-Upgrade "0"; 
13

If your OS uses systemd then:

sudo systemctl mask unattended-upgrade.service

would also stop it from automatically running.

The main issue I have is: why is it taking up 100% CPU for downloading some files?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.