Today I did a regular update for my Ubuntu 14.04 installation on my Dell XPS 13 and the update included a new kernel (I guess it was 3.19.0-65). I noticed that the wireless stopped working after the update and thought that it would be a good idea to switch to an older kernel but it seems that somehow I have messed things up.

The status is: I still have kernels on my machine (3.19.0-65, 3.19.0-64 and 3.19.0-51) and it boots to unity. Screen and touchpad are working, all looks nice, but: It does say that it does not have any network devices at all, so I am totally offline with the laptop.

iwconfig simply gives

lo       no wireless extensions

and nothing else. I found the page My wireless/WiFi connection does not work. What information is needed to diagnose the issue? to diagnose, downloaded the script and tried to transfer it to my laptop with a memory sitck. But my laptop will not even find a usb memory stick anymore! With no network and not usb I am kind of stuck here…

So I am looking for:

  • How do I get my machine up and running again?
  • If the system is broken beyond repair, how could I still get a backup and a reinstall?
  • What happens if you boot with an older kernel?
    – Pilot6
    Jul 15, 2016 at 15:47
  • It looks the same with all kernels.
    – Dirk
    Jul 15, 2016 at 16:25
  • Something is broken. The dongle or USB.
    – Pilot6
    Jul 15, 2016 at 16:41
  • The usb memory stick works at the other machine.
    – Dirk
    Jul 15, 2016 at 16:58
  • And what? How is it related to your problem? Does anything work with USB on THIS machine? Does the dongle work on any other machine?
    – Pilot6
    Jul 15, 2016 at 17:00

4 Answers 4


Had a similar issue after a kernel upgrade: no network, no usb (except the old kernel worked as before).

In this case the linux-image-extra package for that kernel was not installed, so drivers were missing.

To check it's installed:

$ uname -r
$ dpkg -l | grep '^ii' | grep `uname -r`
ii  linux-headers-4.4.0-45-generic             4.4.0-45.66~14.04.1                                                  i386         
ii  linux-image-4.4.0-45-generic               4.4.0-45.66~14.04.1                                                  i386        
ii  linux-image-extra-4.4.0-45-generic         4.4.0-45.66~14.04.1                                                  i386        

If the linux-image-extra package is missing in the list above install it with:

$ sudo apt-get install linux-image-extra-`uname -r`
  • For my kernel I needed the linux-modules-extra instead: "sudo apt-get install linux-modules-extra-uname -r"
    – nmgeek
    Aug 2, 2020 at 19:55

I have exactly the same issue. I run 14.04 on a 2016 XPS 13 Developer-Edition, and after this morning's update the network menu does not contain any wireless device. Wired connection is working fine.

As a workaround, after displaying the GRUB menu and booting into the previous kernel (3.19.0-64), the wireless works as before for me.

Possibly related questions here and here. The same issue has been reported on the Dell forum here. If someone has a forum account, please point them to the various reports on askubuntu. I tried to sign up, but failed. This should also be reported at launchpad.

  • Thanks for pointing me to the bug. Unfortunately this does not solve my problem. When I tried to revert to the old kernel, I must have messed up something else. I try to boot from a stick and see what can be done...
    – Dirk
    Jul 15, 2016 at 18:59

it's me as well experiencing the same issue. Seems like an issue with the 3.19.0-65 kernel. After some mucking around I simply switched back to 3.19.0-64 by

  • pressing ESC on boot to see GRUB's menu
  • enter "Ubuntu options"
  • select Kernel 3.19.0-64-generic


  • Oh, just saw that bas-swinckels did the same. Anyhow, I'll keep the answer here
    – gutschilla
    Jul 18, 2016 at 8:47

This seems to be an issue related to drivers not working starting with Ubuntu's 3.19.0-65 kernel. This is caused by a change made by Canonical whereby kernel and kernel driver signing is now being enforced when secure boot is enabled. During the update process, when a pop-up box asked me to review the secure boot settings, I left them as they were (enabled, I assume).





As recommended in


disabling secure boot from the BIOS corrected the problem for me.

You could also use sudo mokutil --disable-validation from the terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.