29

When I run Nautilus from command line, it starts successfully but this appears in the terminal:

Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: mkdir failed on directory /var/run/samba/msg.lock: Permission denied
net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

Should I really ask my system administrator to enable user sharing?
My administrator is myself, and I don't use Samba.

Is this message the sign of bigger problems with my Ubuntu?
If not, how can I prevent it from appearing? (Nautilus is launched by a program I am beta-testing but can't modify, and the present problem makes this program's errors less visible in the terminal)

23

Nautilus uses the net usershare info command to get information about non-root user defined Samba shares. See the net manpage for more about this command.

If that command fails Nautilus assumes there are no such shares and displays the error message it got just in case you want it.

Creating the folder /var/lib/samba/usershares/ should prevent the message from appearing:

sudo mkdir -p /var/lib/samba/usershares/
  • 3
    Mar 2019: Ths didn't work, but sudo apt install samba did work. – Manohar Reddy Poreddy Mar 21 at 1:59
  • Executing in the following order worked for me: 1. sudo apt install samba 2. sudo mkdir -p /var/lib/samba/usershares/ – Mohsin Bukhari Oct 9 at 6:42
5

I've done these two things to correct this:

sudo mkdir -p /var/lib/samba/usershares/

and

sudo chmod go+rwx /var/lib/samba/usershares/
  • This actually worked for me. First of all, I did not have samba installed. And after I did install samba I got a permission denied error. Doing the chmod trick worked. – assetCorp Jun 30 at 13:07
  • @grégory-mc This method also didn't work for me. Here is the proof: pastebin.com/WfLkri4b – Prabesh bhattarai 2 days ago
1

In my case, didn't have samba installed so I had to install samba and then create the folder.

sudo apt install samba
sudo mkdir -p /var/lib/samba/usershares/

Prior to this had to install tracker because nautilus wasn't even running

(nautilus:26810): Tracker-ERROR **: 12:23:35.259: Unable to find default domain ontology rule /usr/share/tracker/domain-ontologies/default.rule
sudo apt install tracker
1

Another easier solution - Add your user into the group sambashare:

sudo usermod -aG sambashare $USER
0
sudo mkdir -p /var/lib/samba/usershares/ &
sudo chmod go+rwx /var/lib/samba/usershares/

weren't enough, while

sudo apt-get install smbclient 

seems to solved my issue... ty @cbaconnier

0

This is sad. Just to ignore that message, look at what method we need to use.

For me, I had to install samba in Ubuntu 19.10. Tried all method to ignore samba installation but none of them worked. Poor us for using nautilus. And its conflicting Desktop icons not showing in Desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.