I want to compile dsd from github.
Requirements are :

  • cmake
  • mbelib
  • sndfile
  • itpp (IT++) >= v4.3
  • portaudio (optional, improves audio support)

Every thing is ok except itpp package. Because it's version in my Ubuntu 4.2.1 (its installed with: sudo apt-get install libitpp-dev. How I can to upgrade it?

make gives error during compile:

cmakefiles/dsd.dir/src/p25p1_check_nid.cpp.o: In function 'check_NID':p25p1_check_nid.cpp:(.text+0xc1): undefined refrence to 'itpp::BCH::decode(itpp::vec<itpp::bin> const&, itpp::vec<itpp::bin>&, itpp::vec<itpp::bin>&)'
collect2: ld returned 1 exit status
make[2]: *** [dsd] Error 1
make[1]: *** [CmakeFiles/dsd.dir/all] Error 2
make: *** [all] Error 2

In order to use your build of itpp-4.3.1 you will have to remove the Ubuntu 12.04 itpp version : sudo apt-get remove libitpp-dev libitpp7

cd dsd/build/ && cmake ../ && make : No errors, Ubuntu 12.4.5 - 64.

  • i try that you say.... first remove libitpp-dev and libitpp7 and make dsd... but this time error is: fatal error: itpp/itcomm.h: No such file or directory – Ali Begloo Jul 16 '16 at 14:09

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.