0

I'm fairly new to Ubuntu and I've managed to take care of almost everything but brightness. Right from the begining, brightness is at its peak and it's hurting my eyes by now and I have no obvious way to dim it. I have a Lenovo ideapad 500 which I recently bought with a Windows 10/Ubuntu 14.04 partition.

I've tried several tips roaming around, but to no avail.

Here's what I've done:

Modified and updated GRUB file as shown here https://disqus.com/home/discussion/itsfoss/fix_brightness_control_not_working_for_ubuntu_1310/

Added a 20-intel.conf file in the usr folder as mentioned here https://itsfoss.com/fix-brightness-ubuntu-1310/

Later I noticed my sys/class/backlight folder is empty. Somewhere I read that this means that Ubuntu thinks I do have knobs to manually adjust the brightness and all that was left was to file a bug report.

I was stubborn, and following another tip I found that I do have a max_brightness and brightness files buried in /sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0/leds/phy0-led.

Now, here's the funny thing: when I do cat /sys/.../max_brightness and
cat /sys/.../brightness I do get a 1 in both cases. Seems I was right by claiming the brightness is at it's peak. Most of the comments around mention they get 10, 200, 30000 or any other big integer. The only non-negative integer lesser than 1 is 0, and I'm afraid setting the brightness file to 0 will black out the screen.

I tried to set the brightness file to 0.5 just to see what happens, but couldn't do it. Even under the sudo -i prompt, Ubuntu won't let me change its value.

I feel sort of lost. What to do now?

********* EDIT 1 *********

I don't know when it happened, but now I do have a brightness toogle. Funny thing is that it doesn't work at all: brightness won't change even when it is on minimum.

  • What happens when you press the brightness adjust keys on the keyboard? – wjandrea Jul 15 '16 at 0:48
  • What happens when you move the slider in the brightness settings? (to get there: System Settings -> Brightness and lock) – wjandrea Jul 15 '16 at 0:49
  • @wjandrea Keys don't work. The slider on the system settings doesn't work either. – EA304GT Jul 15 '16 at 16:59
  • doesn't work as in, you can't move it, or you move it and nothing happens? – wjandrea Jul 15 '16 at 17:59
  • @wjandrea Doesn't work as there is no change regardless of how I slide it. (I move it but nothing happens) – EA304GT Jul 16 '16 at 3:15

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.