5

I had shockwave flash installed on Ubuntu 15.10 with Firefox. Now I have updated to 16.04, it appears to no longer be available. Or at least I can't find it in the usual ways. I understand it is no longer updated, but where can I get the last version available? Where is it to be found? Or should I re-install Ubuntu 15.10?

  • Have you tried downloading it from the Adobe website? They have an APT package for Ubuntu. – Alcuin Arundel Jul 14 '16 at 21:59
  • 1
    @DavidFoerster: Those are different topics. Shockwave flash refers to the plugin, and an updated overview of Flash on Ubuntu is available on this page. – Gunnar Hjalmarsson Apr 22 '17 at 12:07
4

Info

Q: The difference between the Adobe Shockwave and Flash Players?

A: Shockwave Player displays content created with Adobe Director 11.5 software such as high-performance multiuser games, interactive 3D product simulations, online entertainment, and training applications. By using extensions, developers can extend the capabilities of Shockwave Player to play back custom-built applications.

Flash Player displays content created with Flash Professional CS5. This content includes web applications, website user interfaces, interactive online advertising, and rich Internet applications (RIAs) created using Flex.

Do you really need Shockwave or only Flash plugin?

the flash plugins is available for 16.04 Install Flash Player for Watching Video in Ubuntu 16.04 Xenial Xerus (LTS)

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install flashplugin-installer

Adobe Shockwave Player is not available anymore for Linux. It's obsolete. It doesn't work with modern browsers and operating systems.

enter image description here

The even list PowerPC based Macs. In 2006 Apple switched to Intel.

| improve this answer | |
  • Thanks, it works now. I don' t know what I actually needed. The only message I got was "you need a plug-in to view this site". No indication whatsoever as to which plugin is needed. I don't care whether it's fashionable or not, I just need to be able to view the site. Then comparing with a firefox that works on another computer, the only additional plugin i could see was shockwave flash. – Salvadorfreeman Jul 20 '16 at 22:20
2

Start by doing: sudo apt purge --remove adobe-flashplugin flashplugin-installer pepperflashplugin-nonfree (to remove older versions of flashplugin and pepperflashplugin.

Then do: sudo apt install browser-plugin-freshplayer-pepperflash . If you get any message of a missing file or any error message, go to http://www.ubuntuupdates.org/adobe-flashplugin , select "adobe-flashplugin" 32 or 64-bit deb package and select to open it with "software install(default)". Softaware center will open on adobe-flashplugin page. Press install, then restart your browser and you are done. I hope it helps !

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.