I installed xrdp on my Ubuntu 16.04 (from apt and from sources) and when connecting to my machine and starting eclipse I get a segfault.

When running in gdb I get this output:

program received signal SIGSEGV, Segmentation fault.
rawmemchr () at ../sysdeps/x86_64/rawmemchr.S:37
37 ../sysdeps/x86_64/rawmemchr.S: File or folder not found.

I have the suspicion that it has something to do with graphics, but, what exactly is out of reach for me.

The same eclipse installation worked yesterday via rdp. It also does work when logging in on my machine in the same window manager (mate).

Nonetheless I reinstalled eclipse, but, it did not help.

Update Looking at syslog I see this line:

[ 2457.839200] STS[5200]: segfault at 0 ip 00007f395c8a8b3f sp 
00007ffc917c8948 error 4 in libc-2.23.so[7f395c813000+1c0000

1 Answer 1


Some other question on SO had the solution:
Open GUI apps on a Ubuntu 16.04 machine via SSH from an Ubuntu 14.04 machine
and it solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.