3

So installing updates on my 14.04 64bit UEFI system this morning, got these:

Install: libefivar0:amd64 (0.21-1~14.04.2, automatic), mokutil:amd64 (0.3.0-0ubuntu3~14.04.1, automatic)
Upgrade: shim-signed:amd64 (1.9+0.8-0ubuntu2, 1.17~14.04.1+0.8-0ubuntu2), dkms:amd64 (2.2.0.3-1.1ubuntu5.14.04.5, 2.2.0.3-1.1ubuntu5.14.04.6)

I was presented with a choice to turn off Secure Boot or my "third party drivers" wouldn't work. Not being sure if I had "third party drivers" or not, I consented to turn off Secure Boot.

It all went well, including a reboot, although now I get an annoying "booting in insecure mode" message.

My question is: Is this indication from "Software and Updates" adequate to confirm that I have no "third party drivers" installed?

enter image description here

  • 1
  • If you do not have 3rd party drivers, you can leave Secure Boot on. Did you install any proprietary drivers? – Pilot6 Jul 15 '16 at 8:48
  • @Pilot6 I've updated the question, thanks for the feedback. – Organic Marble Jul 15 '16 at 12:18
  • Out of interest, what kernel are you on? And was a new version of the kernel installed at the same time as these other updates were done? (From the log snippet you included, it looks like the answer would be no, but I just wanted to check.) Thanks – Peter Ford Jul 15 '16 at 13:44
  • 1
    @PeterFord At the time this happened I was on 4.2.0-41. Later that day 4.2.0-42 arrived, but it was not in the same update session. – Organic Marble Jul 15 '16 at 13:47
2

The easiest way to check if you have 3rd party DKMS modules is to use

dkms status

command.

But there is a possibility that you installed some modules without using DKMS. But you should know if you installed something from source.

  • Thanks. From running that command, looks like I have some virtual box modules, so I'd better stick with secure boot off. – Organic Marble Jul 15 '16 at 12:59
1

No, the indication from "Software and Updates" is not adequate to confirm that you have no "third party drivers" installed.

I had the same issue this morning when installed updates to my Dell 64 bit UEFI system (Ubuntu 15.10). I have a dual-boot setup with Windows 10. Back when I installed Ubuntu last year, I had to install a third party driver for the wireless chip, so during this morning's update, I agreed/opted to disable secure boot. In my "additional drivers" tab in settings, it reports (like your screen shot), "no propriety drivers are in use." However, I know I installed a wifi driver from intel, named iwlwifi, which is listed when I issue "lsmod" from the command line.

I too am now getting the "booting in insecure mode" message during boot, but it doesn't bother me - it's a quick small message, and I interpret it in a positive light to mean simply that Windows is not in control of my boot process.

Now on Linux version 4.2.0-42-generic.

  • Thanks! Looks like I am in the same boat with my virtualbox drivers. Glad I opted to disable Secure Boot. My system is also in a dual boot setup with Win 8. I rarely go to Windows, but I tried it and it still boots even with the 'Insecure Boot' message. – Organic Marble Jul 16 '16 at 22:34
  • I'd be interested to know if the dkms status command suggested by the accepted answer "outs" your third party driver. – Organic Marble Jul 16 '16 at 22:35
  • @OrganicMarble - dkms status does not "out" my driver, just shows my vboxhost entries. – Bluesail20 Jul 18 '16 at 16:58
  • Thanks for the reply. So I guess there is no one way to tell if there are 3rd party drivers installed. Unfortunate. – Organic Marble Jul 18 '16 at 17:05
  • "I interpret it in a positive light to mean simply that Windows is not in control of my boot process" I don't think all of us feel this way. The amount of headache I am facing installing my graphic card, and the fact that Ubuntu burns though my laptop's battery because switching and power control is not mature yet -- I would rather that Windows has control of my boot process. Despite spending a week -- and countless login loops and black screens later , I could not get Nvidia to work properly for rendering -- thankfully I am able to use the driver with the "--no-opengl-files" – shaunakde Sep 30 '16 at 14:06
0

Had the same message,... Basically, if you are using proprietary drivers for your video chipset, or your wireless chipset, you are using 3rd party drivers. Commonly, AMD or nVidia drivers are proprietary. Some Atheros and Broadcom drivers are proprietary, as well. A dead giveaway is if you have dkms (Dell Kernel Module Support) run when you do a 'sudo apt-get dist-upgrade' (you typically won't see this unless you do your updates from the command line or you use synaptic package manager and view the update text window).

  • DKMS has nothing to do with Dell. It is Dynamic KMS. There are no Atheros proprietary drivers. – Pilot6 Jul 15 '16 at 8:49
  • @Pilot6 DKMS was literally written by the Linux engineering team at Dell... so I think it's hard to argue it "has nothing to do with Dell" :) (but you're right that it's used for much more than just Dell hardware support) – Nick Weinberg Jul 15 '16 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.