1

I downloaded Steam on Ubuntu 16.04. I was getting a bunch of different errors and managed to fix them by deleting two files: libstdc++ and libgcc_s.

This allowed Steam to open however not Counter Strike.

    $ steam
    Running Steam on ubuntu 16.04 64-bit
    STEAM_RUNTIME is enabled automatically
    /bin/bash: /home/squanchy/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
    grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
    grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
    grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc

Now opening Steam works and opens the application however running it through the command line causes it to exit "running mode??". Not quite sure how to describe it, essentially I can now type in the command line and it stops showing what commands steam is running.

I've tried a bunch of other commands

steam steam://rungameid/730
LD_PRELOAD=’/usr/$LIB/libstdc++.so.6′ DIAPLAY=:0 steam

EDIT: Clarification I hope.

Any help would be nice. Many thanks.

  • > How was Steam installed? > Could you provide screenshots? > Try running this from commandline.. >> LD_PRELOAD='/usr/$LIB/libstdc++.so.6' steam >>> found it here - take a look I run on amd64 too. I'll see what happens when I install & launch CS. Which version? (CS:S,CS:GO) – David your friend Jul 14 '16 at 11:43
  • Yea that did manage to both open steam and counterstrike, however the frame rate was appalling. We are talking about less than 1, as a result I will be switching all of my gaming to the number one gaming platform, aka windows. Thanks a lot none the less. – Yiorgos Makridakis Jul 17 '16 at 15:55
  • 1
    Possible duplicate of Steam won't start on ubuntu GNOME 16.04 – David Foerster Sep 13 '16 at 20:37
  • Yea it probably is. I got the problem sorted however do you know how to delete this post? – Yiorgos Makridakis Oct 14 '16 at 14:06
  • <1 FPS is almost certainly caused by not having the video drivers installed. Just in case anyone wanders by. I play CS:GO a lot via Steam on Kubuntu with an AMD Kaveri chip: sudo apt install xserver-xorg-video-amdgpu takes me from 1FPS to enough to play well. – pbhj Nov 13 '17 at 23:01
1

First backup your CS:GO data (and others games) in order to saving your time to download it back. Your CS:Go should be in ~/.steam/steam/steamapps/common/Counter-Strike\ Global\ Offensive directory.

mv ~/.steam/steam/steamapps/common/Counter-Strike\ Global\ Offensive ~/

remove your current Steam, and install it back by:

sudo apt-get install steam

it should install all dependencies libs. remove the .steam directory in your home before run the app and than mv back the backup files to where it belongs

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.