1

A bit of preface. I have to use 32-bit Firefox on 64-bit Ubuntu 16.04 because of Cisco Webex. Browser I got from archive:

cd ~/32bit && wget -O firefox.tar.bz2 "https://download.mozilla.org/?product=firefox-latest&os=linux&lang=en-US"

And run it with script:

#!/bin/bash
export ENV_HOME=/home/sergius/32bit
export FIREFOX_HOME=$ENV_HOME/firefox
export MOZ_PLUGIN_PATH=$FIREFOX_HOME/plugins
export JDK_HOME=$ENV_HOME/jre1.7.0_80
export JAVA_HOME=$JDK_HOME/jre
export PATH=$JAVA_HOME/bin:$JDK_HOME/bin:$PATH
$FIREFOX_HOME/firefox --no-remote -P 32bit

That's how I've managed to use Cisco Webex (I've googled a lot, only this works for me). And now I have a trouble with browser itself. I noticed problem only yesterday, when tried to fill in html form and simple select object wasn't working. Then I saw, that firefox menu haven't worked at all (click, but nothing happens).

What I was tring to do: 1) moved ~/.mozilla to ~/.mozilla_backup and restart browser - no changes 2) ran script with sudo - and everything became working again! What's wrong?

How to fix this problem?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.