4

I have a BeagleBone running Ubuntu. connman is getting in my way and I'd like to disable it. I deleted /etc/rc*/*connman, but somehow it's still getting started.

(Why am I trying to disable it? Because I'm trying to set a static IP address for eth0 in /etc/network/interfaces, but that doesn't work because evidently connman brings up eth0 first, with no address, which keeps ifup from working.)

4

You can also configure connman to ignore a specific interface.

I had to do exactly the same (static IP for eth0) and could do so by configuring it in /etc/network/interfaces AND by modifying (adding) a line in /etc/connman/main.conf:

NetworkinterfaceBlacklist=eth0,SoftAp0,usb0,usb1
2
  • Thanks for the tip. In the end, I guess, connman or something like it is the way of the future, and we're supposed to use it to configure all network interfaces and stop using /etc/network/interfaces, because /etc/network/interfaces is on the way out. Nov 24 '17 at 14:08
  • This worked for me with a 2018 image. I could not get connman to configure or startup properly with a static IP without a cable plugged in, which ruined my DHCP server that was trying to start...
    – MadHatter
    Jun 14 '18 at 3:18
2

I never did figure out how to disable it, so I ended up just deleting it:

sudo apt remove connman

Now my conventional, static IP configurations (in /etc/network/interfaces) are working fine.

0

You may try running this in the command line:

sudo systemctl disable connman.service

After that other Network Managers should work. Normally Connman is designed for embedded devices.

This worked for me when I had some trouble with Connman on a fresh Ubuntu Studio 21.04 installation (lost Internet connection).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.