2

After running sudo apt upgrade, my perf was broken:

$ perf
/usr/lib/linux-tools/4.4.0-28-generic/perf:
error while loading shared libraries:
libbfd-2.26-system.so: cannot open shared object file: No such file or directory

I tried to apt remove linux-tools-common then reinstall, to no avail.

How can this be fixed?

Using Ubuntu 16.04.

4

I just ran into the same problem. Looks like libbfd got updated but perf is still trying to link against the old version. I worked around the issue by symlinking to the library:

$ sudo updatedb
$ locate libbfd
/usr/lib/x86_64-linux-gnu/libbfd-2.26.1-system.so
$ sudo ln -s /usr/lib/x86_64-linux-gnu/libbfd-2.26.1-system.so /usr/lib/x86_64-linux-gnu/libbfd-2.26-system.so
$ perf
  usage: perf [--version] [--help] [OPTIONS] COMMAND [ARGS]
..

Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.