1

It all started with me wanting to use OpenGL 4 to play games on my ubuntu 16.04 laptop. I was running on intel integrated graphics and even if the processor is suppose to handle OpenGL 4 I could not find a way to install it as intel drivers are already installed on 16.04.

However i quickly realized that I have another video adapter on my laptop : [AMD/ATI] Mars XTX [Radeon HD 8790M]

So I tried to make this one work by installing AMD proprietary drivers (fglrx). I activated them in the additional driver setting but I cannot for some reason switch from intel graphic to my AMD GPU.

I looked everywhere and trying a bit everything. Using amdconfig gives me: no suported adapter detected.

I am running out of ideas and would appreciate any advise. P.S: I am no expert at ubuntu.

EDIT: AMD proprietary driver do not work on ubuntu 16.04. I would therefore try to get OpenGL 4 to work on intel graphics. The only information I got as for driver is that it is i915. The laptop has a i7-4810MQ which runs Intel® HD Graphics 4600. This is suppose to run openGL 4.3 ....

0

fglrx is not supported on 16.04. See here for more details.

  • Great, so I am better off with the intel HD graphics since AMD open source driver won't support openGL... – Twinsun Jul 13 '16 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.