0

For a long time, software updater does not update. When it notifies there are available updates, I run install and it starts; however, after 1-2 seconds it suddenly disappear and does not update obviously. Before it disappears, at the bottom of the progress window, it says something like 'Waiting for authentication' (but I am not sure because it disappears very very fast. Though I run it again and again, I couldn't read it precisely)

I run these commands from the terminal to update manually:

sudo apt-get install update
sudo apt-get install upgrade

After that, some of the updates(e.g chromium etc.) has been installed but there are others that are not updated:

Here is the left ones

0

You are trying to do something the commands are not built to do! The correct way to update is :

Sudo apt-get update

This update the cash. The new way is:

Sudo apt update

Likewise with the actual upgrade:

Sudo apt-get upgrade  /  sudo apt upgrade

Do see the manual for the install options, You have installed the Update and the Upgrade programs, they come standard with any Ubuntu flavor, and most other Debians!

2
  • Have you read this : askubuntu.com/questions/445384/….? Both apt and apt-get should work. Actually apt-get gives you more options than apt. – ipse lute Jul 13 '16 at 17:07
  • It does the job! Though, in the link above it says they are same, apt has upgrade flag --with-new-pckgs. I think this is why it worked. However, why the Software Updater couldn't do that and how to fix it are still a mystery for me! – Aka Jul 13 '16 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.