I cannot start FileZilla. When I do it, nothing happen. I tried uninstalling and then reinstalling it, but no help. I am using Ubuntu 16.04.

If I start it from the command line, I see the following:

Reading locale option from /home/superuser/.config/filezilla/filezilla.xml

(filezilla:16389): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed
(filezilla:16389): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
(filezilla:16389): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed
(filezilla:16389): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
(filezilla:16389): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
(filezilla:16389): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'height >= -1' failed
(filezilla:16389): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion 'width >= -1' failed
Program segmentation fault ( core dumped )
  • 3
    Any error messages if you start it from the command line?
    – andrew.46
    Jul 13, 2016 at 6:59
  • Try running the following command: mv -v /home/superuser/.config/filezilla/ /home/superuser/.config/filezilla_bak and then reopen filezilla
    – andrew.46
    Jul 13, 2016 at 8:42
  • @andrew.46 Yes, can open now. Thank you very very much!!!
    – velut luna
    Jul 13, 2016 at 8:52
  • Would you reconsider taking this answer as the accepted one as that's better than the existing one which just wipes the entire config. 0:-)
    – Fabby
    Sep 15, 2019 at 17:27

6 Answers 6


You can reset FileZilla to defaults by making sure that all copies of FileZilla are definitely closed and then running the following command:

mv -v /home/superuser/.config/filezilla/ /home/superuser/.config/filezilla_bak

Then reopen FileZilla which will build a new, clean set of local preferences. This should be enough to get around what is more than likely a bad, local configuration file.

  • Could you tell me what the -v here means?
    – velut luna
    Jul 13, 2016 at 11:04
  • This option enables 'verbose' and thus the movement of the directory is printed out in detail on your terminal screen.
    – andrew.46
    Jul 13, 2016 at 11:06
  • Confirmed work on Linux Mint 18 (based on Ubuntu 16.04), thanks.
    – Carson Ip
    Dec 9, 2016 at 4:59

I had the exact same issue. I presumed there was an issue with the filezilla.xml file. I went to /home/$USER/.config/Filezilla/ deleted the old filezilla.xml file.

Then went back into the terminal and typed "filezilla" to open the program. For me, it opened fine and it created a brand-new default XML file in the old file's place. The site manager options are not affected by this as they are in a different file called "sitemanager.xml" which is in the same directory. So the program opened as a fresh new program with the same site manager options as before.


Go to ~/.config/Filezilla or ~/.filezilla.

You need to press Ctrl+H to show hidden files if necessary.

Then open filezilla.xml using a text editor.

Remove the Last local directory tag.

Save the file again and reopen filezilla.

This works for me every time.

  • This just worked for me using FileZilla under Ubuntu 16.04.3
    – user607207
    Dec 2, 2017 at 19:45
  • Works a treat - saves having to recreate all the settings again - this needs to be filed as a bug report in FileZilla
    – Amr Bekhit
    Feb 16, 2018 at 14:39

In addition to andrew.46 answer, you can now import the old sitemanager.xml file in the backup folder once filezilla opens. Use File->Import menu. This is useful if you had a lot of sites saved.



In filezilla.xml there is the empty element <Setting name="Language Code" type="string" />. If you add an installed locale such as en_GB.UTF-8 (use locale -a to find available locales), so that you get <Setting name="Language Code" type="string">en_GB.UTF-8</Setting> everything should run smoothly again.

The long version:

I recently ran into this problem as well, using Ubuntu 16.04.3 and FileZilla

The solutions posted here are based on deleting stuff, but that did not solve my problem. I could start FileZilla again, indeed, but it would still crash on start-up if the last local directory contained non-ASCII characters. File and directory names with non-ASCII characters were just blank. Uploading these was also no good idea.

The following line is the culprit:

<Setting name="Language Code" type="string" />

as I would have expected some language or encoding (such as ISO 8859-15). So, I tried one of my installed locales:

<Setting name="Language Code" type="string">en_GB.UTF-8</Setting>

Now, starting FileZilla would show files and directories with non-ASCII characters again.

If you want to find out which locales you have installed, use:

locale -a

If you are not sure whether you are also affected by this issue, this might help: When running filezilla --version with the empty language code, the output looks like this:

Reading locale option from /home/kreuvf/.filezilla/filezilla.xml
FileZilla, compiled on 2016-02-25

Another indicator I remembered when reading a related question is the following entry in the kern.log:

kernel: [39162.363835] traps: filezilla[19354] general protection ip:7f99fa048ce6 sp:7fff363ae5e0 error:0 in libwx_gtk2u_core-3.0.so.0.2.0[7f99f9b48000+5f9000]

The different message compared to the linked question may stem from different kernels (more than three years difference) and all the accompanying things that might have changed in the meantime. Nonetheless, in both cases it is libwx_gtk2u_core-3.0.so.0.2.0 and also the offset (?) of 5f9000 matches.

So, if it looks like that for you, chances are good that this solution will work for you. If things are working correctly again, it should look like this:

Reading locale option from /home/kreuvf/.filezilla/filezilla.xml
setlocale en_GB.UTF-8 successful
locale set to en_GB.UTF-8
FileZilla, compiled on 2016-02-25
  • bounty awarded! Thanks for this!
    – Fabby
    Aug 31, 2019 at 17:39

Probably last known window size has become invalid due to a crash or something, as the error message states here:

assertion 'height >= -1' failed

Look for a line into your /home/superuser/.config/filezilla/filezilla.xml file containing:

<Setting name="Window position and size">0 14 38 1098 576 </Setting>

It'll have different values, probably some could be negative. If the line doesn't exist just add it before the line with </Settings>

Use the settings I posted above, as good known state.

Save filezilla.xml and you now should be able to open Filezilla again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.