0

I'm running the latest ntpd.

When I start ntpd my system time synchronizes with ntp server's ntp. After synchronizing I changed my system time manually using date command date -s '1997-02-22 12:00:00'

My system time got changed as per the date command.

NTPD is still running, I want to know at what time interval my system time will sync with the internet via ntp.

1

Generally we can also call it as polling interval and minimum time is 64 sec and maximum time 1024 sec , but you can still change it as you want by doing changes at /etc/ntp.conf.

minpoll minpoll

maxpoll maxpoll

These options specify the minimum and maximum poll intervals for NTP messages, in seconds as a power of two. The maximum poll interval defaults to 10 (1,024 s), but can be increased by the maxpoll option to an upper limit of 17 (36.4 h). The minimum poll interval defaults to 6 (64 s), but can be decreased by the minpoll option to a lower limit of 3 (8 s). These option are valid only with the server and peer commands.

  • thanks Raja. I'm seeing one more issue.My ntpd is crashing with the error message "event at 1020 0.0.0.0 0617 07 panic_stop +611777596 s; set clock manually within 1000 s. event at 1020 0.0.0.0 061d 0d kern kernel time sync disabled ". Do you have any idea regarding this – Sharath Manchala Jul 13 '16 at 7:12
  • 1
    @SharathManchala forums.freebsd.org/threads/53885 – rɑːdʒɑ Jul 13 '16 at 7:15
  • @SharathManchala novell.com/coolsolutions/feature/15345.html – rɑːdʒɑ Jul 13 '16 at 7:15
  • my understanding was if we dont configure minpoll and maxpoll then it sets default values as 64s and 1024s(17 mins). Is it dam sure that within this interval time will get sync from server. – Sharath Manchala Jul 13 '16 at 9:44
1

What is is saying is "event at 1020 0.0.0.0 0617 07 panic_stop +611777596 s; set clock manually within 1000 s. event at 1020 0.0.0.0 061d 0d kern kernel time sync disabled " because of event that happened ntpd stopped. The event is you changing the time of the clock. NTPD is angry that you changed the time of the clock too far away form the time that it knows, and NTPD wants you to make sure you get the time within within 1000s or 16 minutes. NTPD does not like having to jump too far. For example if you computer did not have a internet connection for a long time and then you reconnected it, it would not jump to the correct time right away, but slowly get the time closer until it was correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.