I am running into another issue where the XRDP is not working. I have been at it for quite some time now and I think that I need help. I believe that it is an issue of the Ubuntu machine not listening on a port.

I followed the guide at http://www.tweaking4all.com/software/linux-software/use-xrdp-remote-access-ubuntu-14-04/.

However, when I go to rdp from windows, I am able to connect and type in username and password but when I do, I get the following error:

Connecting to sesman IP port 3350
sesman connect ok
sending login info to session manager, please wait...
srdp_mm_process_login_response:login successful for display
started connecting
connecting to 5910
error-problem connecting

Could the issue be that my Ubuntu machine is not listening to port 5910? WHat do you guys think? If so, how can I make sure that Ubuntu is listening to port 5910?


Ok, so when I run this command:

sudo netstat -peant | grep ":5910 "

Nothing comes up. When I run this command: sudo netstat -peant | grep "" and I scroll through, I do not see anything connected to port 5910. I believe that i have found a large issue. My question now is how do I set up xrdp to listen to port 5910?

7 Answers 7


I found this one really worked for me. https://ubuntuforums.org/showthread.php?t=1314336

I summarize here the solution:

I had to remove xrdp, vnc4server, tightvnc, which were all installed in the wrong order. I had to install tightvncserver, then install xrdp.

sudo apt-get remove xrdp vnc4server tightvncserver
sudo apt-get install tightvncserver
sudo apt-get install xrdp

Then restart the xrdp service:

sudo service xrdp restart
  • Now I can login, but it logs out back in 1-2 seconds.
    – stiv
    Commented Mar 28, 2018 at 15:48
  • It works for me. Before seeing this answer I didn't even have any VNC server installed.
    – smbear
    Commented Sep 28, 2019 at 19:22
  • 3
    Frustratingly, this worked for me. I have no idea what changed as I had been using xrdp for months before it went haywire. Thanks!
    – jgitter
    Commented Dec 5, 2019 at 16:34
  • This solution works for me too.
    – Harper
    Commented Sep 23, 2021 at 19:13
  • I had not only to remove the packages, I also needed to purge them (sudo apt-get purge xrdp && sudo apt-get purge tightvncserver) and reinstall them in the indicated order. Plus "allowed_users=anybody" in the /etc/X11/Xwrapper.config file. Commented May 8, 2023 at 20:34

It's not worth it - there is a better & less painful solution:


I spent at least 8 hours fighting the battle to connect from Windows 10 to Ubuntu 16 via xrpd and Windows rdp. I tried endless "solutions" that I found posted all over the web. I made progress, but never managed to fully solve it. Even if I had, though, it seems that this is weak setup anyway, because:

  • You can't use the Unity Desktop, so your rdp has connect you to a completely different OS UI than what you would use as the Ubuntu standard.
  • You can't be logged on already with that account. So if you were have a scenerio where sometimes you work directly on the Ubuntu machine, and sometimes you connect remotely, you'd have to be sure to log out to allow for that remote connection.
  • From what've read, once you have this, you have also fight a battle to get a "re-connection" mechanism working to re-enter an rdp session you left.
  • You have to manually enter credentials every time you log on. There is no way to save them on the client end and just connect instantly.

I've used a pile of different remote connection interfaces, and overall nothing beats the ease and quality of Windows RDP yet to my mind. A such, I was pretty fixated on using that. After fighting this long enough though, and finally throwing in the towel, I found that VNC pretty much works just as well in this context.

As I said initially, on the Ubuntu side I used "x11vnc". Refer to these directions for details on getting that fully setup:

How to setup x11vnc to access with graphical login screen?

On the Windows side, I used RealVNC Viewer: https://www.realvnc.com/en/connect/download/viewer/, which I already had installed and setup for a remote connection to a Mac on my LAN as well.

With this setup, I have NONE of the weaknesses outlined above. Further, in full screen mode, the display is just as good as it would be naturally. I see 0 lag, 0 blurring. I have a bi-directional clipboard working without any effort to get that...

In theory, you are supposed to be able to stack xrpd and x11vnc. See: http://c-nergy.be/blog/?p=5956 I tried that too, just to see if I could get it to work. I had no luck with that either. So I just said the hell with xrpd in the end, uninstalled it, and rolled back all the changes I made to my machine fighting with it (or least so of them).

Unless you have a major reason that you NEED RDP instead of VNC, I strongly recommend going this route I've described instead.

  • Thanks, this worked perfectly on the first try. x11vnc in Linux Mint, RealVNC viewer in Windows, worked right away. Commented Oct 16, 2020 at 6:49
  • flawless connection from Win10 to RaspberryPi running X11VNC on it.
    – smartini
    Commented Nov 2, 2022 at 13:27

Ok, so i found the command that will solve my issue. Run this command to remove the error

Run gsettings set org.gnome.Vino require-encryption false

  • 2
    when i run it in the terminal of raspberry pi it wrote "No such schema 'org.gnome.Vino'"
    – ofir_aghai
    Commented May 30, 2019 at 9:09
  • It gives an error.
    – Sachin
    Commented Nov 29, 2021 at 9:58

This post helped me get rid of the issue. I restarted the xrdp service afterwards just to make sure too.

Have you tried creating a file /etc/X11/Xwrapper.config containing

allowed_users = anybody

Note that I am using windows 10 to connect debian 9. And I used Xorg.

  • 1
    Same problem here Debian 9.5 and Fluxbox.
    – ceving
    Commented Oct 27, 2018 at 14:07
  • 2
    worked for me. default allowed_users was set to console
    – osyan
    Commented Jan 5, 2019 at 11:53

I struggled some days in this problem (Windows 7 Remote Desktop Connection - XRDP CentOS), and by searching I found that the simplest solution for error - problem connecting is clear "mydomain\username" login: before installing packages, kill processes or remove temporary files, just try to connect writing your username only in the XRDP request, so do not save it previously in the Windows 7 Remote Desktop Connection.

If you are not allowed to clear your username (XRDP always showing a name by default), clear the RDP connection history for the server you are trying to connect, or take this as an opportunity to clear all connection history, this way (Windows side - CMD):

@echo off
reg delete "HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default" /va /f
reg delete "HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers" /f
reg add "HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers"
cd %userprofile%\documents\
attrib Default.rdp -s -h
del Default.rdp

And then try again to connect. If it doesn't work, you can try:

  1. Keep in mind you should use High Color (16 bits) or higher in Windows RDP; or

  2. Access xrdp-sesman.log by PuTTY (cat /var/log/xrdp-sesman.log), what will problably show "X server for display 10 startup timeout (...) another Xserver is already active on display 10", then vncserver -geometry 1024x768 :10 will show there is a temporary file you can clear, so remove the correct temporary files as explained here and here; or

  3. Downgrade Tiger VNC.


I am very new and I have read bugs and docs regarding this.

All I did to fix this issue was to stop and start xrdp, using these commands:

sudo service xrdp stop

sudo service xrdp start
  • Worked for me. xRDP, was working on port 3350.
    – Luis Lopez
    Commented Apr 6, 2019 at 2:17

Just change: /etc/xrdp/sesman.ini AllowRootLogin=1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .