38

The recipies for changing one's login screen in 14.04 [EDIT or in 15.04, 15.10] don't work in 16.04. The "custom" background shows for a split second and then fades to the Ubuntu one. So, how do I change the login screen background in 16.04?

[Edit: this post is not a duplicate because all other related questions specifically refer to previous versions of Ubuntu, and the solutions to those do not apply here (as they do not work on 16.04).]

  • I'm also seeing this problem – seanlano Jul 31 '16 at 2:34
  • The non coder way is to use Ubuntu Tweak. You can find out how to get it here askubuntu.com/questions/770947/… – Organic Marble Nov 8 '16 at 20:08
  • @OrganicMarble thanks for the suggestion, but Ubuntu Tweak seems to only be able to change the Lock screen, which I've already changed using other methods. The login screen is still the same. And, theoretically speaking, if the (slightly) old recipes for changing the login screen manually do not work, and Ubuntu Tweak is abandonware, one cannot expect it to be able to succeed in the task. – Greg Kramida Jan 3 '17 at 18:57
  • @GregKramida if this doesn't apply, you need to edit your post to explain why it is not a duplicate, or make a comment to that effect. Once that is done, I'll reopen this for you, if the duplicate and its answers don't help – Thomas Ward Jan 3 '17 at 22:22
  • @ThomasWard, thank you, I just edited the question. – Greg Kramida Jan 3 '17 at 22:29
27
+50

You said:

The "custom" background shows for a split second and then fades to the Ubuntu one.

The greeter by default load the selected user background if it is available. A fade transition used to change between backgrounds of users including greeter default (for guest user). I think that the question should: How to stop lightdm greeter from loading the user background?

Be aware of two distinct greeters, default is unity-greeter. I noticed that some answer here in AU, don't mention this and mix up between them.

Using lightdm-gtk-greeter

GUI tool

  1. Install the settings tool

    sudo apt install lightdm-gtk-greeter-settings
    
  2. Run it

    pkexec lightdm-gtk-greeter-settings
    
  3. In Appearance tab: Select the image

  4. On same tab: Unckeck User user wallpaper if available
  5. Save & Close

    lightdm-gtk-greeter-settings

CLI tools

  1. Open lightdm greeter settings file

    sudo nano /etc/lightdm/lightdm-gtk-greeter.conf
    
  2. Change it this way

    [greeter]
    background = /usr/share/backgrounds/Spring_by_Peter_Apas.jpg
    user-background = false
    
  3. Ctrl+o to save it then Ctrl+x to exit.

Using unity-greeter (default)

Same answer by Serg, I have tested it in a fresh VBox Ubuntu 16.04.

  • Change the background of the login screen

    $ sudo nano /usr/share/glib-2.0/schemas/10_unity_greeter_background.gschema.override
    
    [com.canonical.unity-greeter]
    draw-user-backgrounds=false
    background='/usr/share/backgrounds/Spring_by_Peter_Apas.jpg'
    
    $ sudo glib-compile-schemas /usr/share/glib-2.0/schemas
    $ sudo service lightdm restart
    
  • Some debug hints:

    1. Purge lightdm-gtk-greeter settings

      sudo apt purge lightdm-gtk-greeter lightdm-gtk-greeter-settings
      

      Or you may want just disabling it temporary

      sudo mv /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf.disabled
      

      To enable it back

      sudo mv /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf.disabled /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
      

      Restarting the lightdm is needed

      sudo systemctl restart lightdm
      
    2. Reinstall unity-greeter to remove any change in /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml

      sudo apt install --reinstall unity-greeter
      
    3. Check if there any other dconf override file that take priority

      grep -rn -e "com.canonical.unity-greeter" -e "background=" -e "draw-user-backgrounds=" /usr/share/glib-2.0/schemas/
      
  • 1
    The critical thing was "Unckeck User user wallpaper if available", which finally removed the fade-to-purple effect. However, the login screen still looks different after installing the said package. This is the old look: tecmint.com/wp-content/uploads/2016/02/…. Note how the login block is left-aligned versus the centered look I'm getting now. I'm going to test the other solutions suggested here on my home machine later to see if they work without messing that up. – Greg Kramida Jan 9 '17 at 18:52
  • This appears to be the only way that really works so far. I hate to have to install the lightdm-gtk-greeter for this, I actually like the unity one so much better... Well, gotta choose the the lesser of the two evils :-) – Greg Kramida Jan 9 '17 at 19:02
  • 1
    @GregKramida,:) believe me I did notice that they are two distinct greeters lightdm-gtk-greeter & unity-greeter/default . and I think I found how to make same setup on unity-greeter , I will test it and update my answer. – user.dz Jan 9 '17 at 19:27
  • 1
    @GregKramida, For unity-greeter, it is :) same answer as askubuntu.com/a/694370/26246 tested and it works fine in vbox 16.04 fresh install . AlI can think of, that you have to purge any lightdm-gtk-greeter related settings using sudo apt purge lightdm-gtk-greeter lightdm-gtk-greeter-settings before trying that solution. I noticed that many solution mix up between the two greeters. If it is worth, I may try it in 16.10 if you want? – user.dz Jan 9 '17 at 20:32
  • 1
    @Serg Greg already knew the step was missing in the original version of my answer as he pointed it out to me before you did. It's been revised and the spreadsheet has been recalculated so the new script with comment is in place. So that mistake at least will never happen again. Thanks :) – WinEunuuchs2Unix Jan 10 '17 at 0:20
4

To change the login screen in Ubuntu 16.04 I used the following:

gksu gedit /usr/share/glib-2.0/schemas/10_unity_greeter_background.gschema.override

Insert these lines:

[com.canonical.unity-greeter]
draw-user-backgrounds=false
background='/home/$USER/Pictures/1920x1080-TuxSuckingWindowsTetraWwallpaper.jpg'
# After changing use: sudo glib-compile-schemas /usr/share/glib-2.0/schemas

Where:

  • $USER = your user ID.
  • Pictures = your wallpaper directory.
  • 1920x1080-TuxSuckingWindowsTetraWwallpaper.jpg = your image file name (can be .png format too).
  • # (comment) ... reminds you what to do after changing!

Save the file and exit gedit

Now compile the new login wallpaper with:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas

Last step is to reboot.

Many thanks and credit to Serg: (Change the background of the login screen) Note on my system this no only changes the initial login screen but also the lock screen login as well.


Point and click with Nautilus to set login screen wallpaper

I wrote a script where you can navigate to a directory / image, right click on it and set it as login screen / lock screen background using Nautilus (file manager now called "Files"): Nautilus can set desktop wallpaper. How can it set login and lock screen wallpaper?

Nautilus set-login-wallpaper Drop Down

  • Well, I'm sorry, but this just doesn't work for some reason. I'm on 16.10 at this time, btw, a lot of time has passed since the original question was posted. I don't think that's what's making the difference, though, since I'm experiencing the same effects as I did back in 16.04: I see that custom picture that I set for a split second, then it fades to the default Ubuntu purple one. – Greg Kramida Jan 9 '17 at 18:57
  • I think mine flashes the purple for a split second before mounting my real wallpaper. My 16.04 was upgraded from 14.04 but never tried wallpaper until after upgrade. – WinEunuuchs2Unix Jan 9 '17 at 22:48
  • I'll mark your answer up, because it seems like, thanks to experiment by @user.dz, it would work for some, or even most, users. I would suggest to post a link to the original one or include the missing two steps, though: askubuntu.com/questions/694202/… – Greg Kramida Jan 9 '17 at 23:05
  • The important step that you're missing here is to sudo glib-compile-schemas /usr/share/glib-2.0/schemas. – Sergiy Kolodyazhnyy Jan 9 '17 at 23:18
  • Yes I saw that when I read the link on my phone. In the process of updating now that I'm home again. I had copied out of my spreadsheet and missed the line last night. – WinEunuuchs2Unix Jan 9 '17 at 23:47
1

Run sudo lightdm-gtk-greeter-settings (if installed). Go to the Appearance tab, and select Background > Image.

Note: If you're selecting an image from your home folder and the folder's encrypted, it won't work, because /home/user hasn't been mounted yet.

  • 1
    Thanks for the suggestion, but this solution seems to have the same effect as many of the solutions for the previous Ubuntu versions. I see the image I set for a split second and then it fades to the aggravating purpleness off the default image... I think the startup screen also looks very different after setting up that package (which also installed a few others), now I don't know how to get the old look back... – Greg Kramida Jan 5 '17 at 14:23
0

As @OrganicMarble said, Ubuntu Tweak should do the trick. I installed it and in the Tweaks tab there is a tab called 'Login settings'. Unlock the page in the top right by entering the password and you can change the settings wallpaper. Since then my login and lock screens were changed.

  • Nope, sorry, same as before, shows custom image for split second and fades to purple. The only thing I see this change for me is the lock screen. – Greg Kramida Jan 9 '17 at 19:01
0

This worked well for me on 16.04 LTS and without installing extra-software https://www.linuxslaves.com/2016/06/easiest-way-change-ubuntu-login-screen-background.html

In short: Open sudo gedit /usr/share/gnome-background-properties/xenial-wallpapers.xml and add your background image to the list. Then open the "Change background image" by right-clicking on your desktop, select the image and it's done for both working and login screen. Eventually restart to try it out.

0

To set the unity greeter as default, in Ubuntu 16.04 login screen, edit the file

/usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf

and change the "greeter-session" line to "greeter-session=unity-greeter"

0

Duo Step-

  1. sudo cp Downloads/human_ubuntu-wallpaper-1366x768.jpg /usr/share/backgrounds/
  2. sudo mv /usr/share/backgrounds/human_ubuntu-wallpaper-1366x768.jpg /usr/share/backgrounds/warty-final-ubuntu.png

Just lock and comment!

protected by Community Feb 25 '18 at 19:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.