0

I have installed python 2.7 and python 3.3 on server and now I need to install pip for python 3.3.

Here's what I have tried so far:

sudo apt-get install python3-setuptools
sudo easy_install3 pip

This will install pip for python 3.2 (I haven't installed python 3.2)

sudo apt-get install python3-pip

This will install pip for python 3.2

I need to install some packages with python 3.3 (lxml, ftplib, etc...) and for that I need pip.

I cannot setup only python 3.3 because I also need python 2.7 (for odoo).

Can anyone guide me in proper direction.

  • Try adding python3.3 to PATHas explained in this link. – Waqas Jul 12 '16 at 12:47
  • I already refer this, can please elaborate more what I need to add it to the PATH ? – Emipro Technologies Pvt. Ltd. Jul 12 '16 at 12:55
0

» I need to install some packages with python 3.3 (lxml, ftplib, etc...) and for that I need pip «

Then please do dpkg -L python3-pip to know that the python3-pip is /usr/bin/pip3

Installing with pip3 : pip3 install [package]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.