On my desktop running Oneiric, sometimes there's no sound at all, but it would work normally at other times. My setup is built ground-up from minimal Ubuntu, but since sounds work fine, at times, I don't think it is a backend dependency issue. When it works, it will play anything from regular audio files and movies to YouTube Flash players.

For the record, I installed LXDE with the alsa-base and alsa-utils packages which are the only audio-related dependencies for the lubuntu-desktop.

For a while, I also used persistent Oneiric live USB, and do not recall any sound issues.

It's one thing to not play sound entirely, but playing sound only under some very unclear circumstances is something else. Please help me diagnose it.

  • @WarriorIng64 I highly doubt a DE has got anything to do with sound issues. – Oxwivi Nov 16 '11 at 12:46
  • You mentioned installing LXDE with audio-related dependencies prior to experiencing these issues, so I wasn't sure if it was relevant or not. – Christopher Kyle Horton Nov 16 '11 at 13:04
  • @WarriorIng64 Well, I was just describing what audio backends I've installed, and why. – Oxwivi Nov 16 '11 at 13:48

Maybe you have problems with alsa-mixer configuration.

First thing I would do on your place is go to terminal and type "alsa-mixer". This will bring you to audio settings and you can explore it and something might be wrong there. It has a built in help so you it shouldn't be hard to do things you want.

If it works at least sometimes then hardware-side is ok.

My guess is that some software just changes audio settings to its' needs and breaks stuff.

Would be useful if you could provide circumstances when it works or not.

You can always reinstall alsa to check if some dependencies are missing.

P.S.: I myself use similar system, but I installed lxde(not lubuntu-desktop) over minimal installation, so I should have even less stuff installed.

| improve this answer | |
  • That's the thing, I cannot determine the circumstances. Sometimes I boot into the computer and it's working, and sometimes it's not. – Oxwivi Nov 16 '11 at 15:01
  • might be also some hardware problem (some wire damaged etc.). And about the conditions, you could experiment(if you have time) with programs running while shutting down or programs used while turned on, which have anything to do with sound. – foxy Nov 17 '11 at 9:48

first sorry about my english

I have the same problem, and I found this thread about that.

In a "muted" session I have changed pulse audio configuration as explained there, and killed the process pulseaudio, and I hear again the sound.

I still need to check if it will work after restarts.

I hope this help you.

| improve this answer | |

I've had the same problem with XUbuntu 11.10 after removing pulseaudio.

If you have more than one sound card, ALSA does not always automatically default to the same card.

I had onboard audio, a Sound Blaster PCI card and the integrated audio in a Nvidia Geforce 210 card (a lot of NVidia video cards have an audio controller so that they can output audio thru the HDMI port).

So, sometimes audio would output thru the Sound Blaster, everything was OK. Other times, it seemed to be mute. After some googling, I came up with instructions on how to make ALSA always use my preferred sound card:


| improve this answer | |
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Oyibo Nov 11 '12 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.