4

I was trying to use Ubuntu 16.04 cloud image xenial-server-cloudimg-amd64-disk1.vmdk [downloaded from https://cloud-images.ubuntu.com/xenial/current/ ] on VirtualBox but facing two problems:

  1. Booting the VM stops indefinitely following the message "...random: nonblocking pool is initialized ". The same VM image on Vmware workstation takes to the the 'ubuntu login' successfully.

  2. Since the cloud image doesn't have ubuntu password, I tried to pass this with "init=/usr/lib/cloud-init/uncloud-init ds=nocloud ubuntu-pass=ubuntu" as described in https://help.ubuntu.com/community/UEC/Images/KVMKernelOptions, but it doesn't seem to work as the login doesn't accept the password.

Thanks for any help regarding the issues.

  • I can not login neither, waiting for answers – soulmachine Oct 11 '16 at 22:34
2

Instead of what you are doing

As your question is old, these may be better ways to start 16.04 virtual machines.

Answer to your Question

As you asked specifically about virtualbox, as of the current writing, I see the following issues in your current procedure:

  1. You need to enable a serial port on your virtual box machine. In the UI, it's a matter of checking the 'serial port' box. The vboxmanage cli also has a way to do this.
  2. I see you are modifying the kernel command line, but I don't know how to do that in virtualbox, so instead, I attach an .iso with the right cloud config following a modification of this procedure.

Virtualbox cloud-image procedure

This is modified from the reference procedure, but worked for me

  • Download the latest 16.04 .vmdk file
  • Create the seed.iso with #cloud-config (see below)
  • Create a virtualbox VM
    • disk: point to ubuntu-16.04.vmdk download
    • cdrom: seed.iso
    • enable serial port
  • Upon boot, I can login.

Creating a seed.iso

## create user-data file and a iso file with that user-data on it.
$ seed_iso="my-seed.iso"
$ cat > my-user-data <<EOF
#cloud-config
password: passw0rd
chpasswd: { expire: False }
ssh_pwauth: True
EOF
$ cloud-localds "$seed_iso" my-user-data

References

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.