5

I am using Tata Photon Max Wifi to connect to internet. Since morning download speed is decreasing to 10-15 kbps. Normal speed I receive is usually more than 200 kbps. I have not changed any settings or done anything that may cause this.

I checked downloading speed on mobile and it is normal there (>200 kbps). Also web surfing speed is also normal only during downloads the speed starts decreasing.

I searched for some solution but none of them are working/. This is some output that may be important.

sudo lshw -C network
*-network               
   description: Wireless interface
   product: AR9485 Wireless Network Adapter
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlp2s0
   version: 01
   serial: 28:e3:47:52:b3:92
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=4.4.0-28-generic firmware=N/A ip=192.168.1.101 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:18 memory:f3500000-f357ffff memory:f3580000-f358ffff
*-network
   description: Ethernet interface
   product: AR8162 Fast Ethernet
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: enp3s0
   version: 10
   serial: 54:ee:75:01:42:5f
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
   resources: irq:47 memory:f3400000-f343ffff ioport:4000(size=128)


 lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Qualcomm Atheros AR8162 Fast Ethernet (rev 10)
04:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)

If anything else may be required please ask me.

Edit Here's the link to ubuntu forum wireless script result

Edit

iwlist scan
lo        Interface doesn't support scanning.

enp3s0    Interface doesn't support scanning.

wlp2s0    Scan completed :
      Cell 01 - Address: 00:F8:1C:FE:0F:26
                Channel:6
                Frequency:2.437 GHz (Channel 6)
                Quality=31/70  Signal level=-79 dBm  
                Encryption key:on
                ESSID:"Tata-Photon-Max-Wi-Fi-0F26"
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                          24 Mb/s; 36 Mb/s; 54 Mb/s
                Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                Mode:Master
                Extra:tsf=0000000398ce762d
                Extra: Last beacon: 84ms ago
                IE: Unknown: 001A546174612D50686F746F6E2D4D61782D57692D46692D30463236
                IE: Unknown: 010882848B962430486C
                IE: Unknown: 030106
                IE: Unknown: 2A0100
                IE: Unknown: 2F0100
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : CCMP TKIP
                    Authentication Suites (1) : PSK
                IE: Unknown: 32040C121860
                IE: Unknown: 2D1A001118FF00000000000000000000000000000000000000000000
                IE: Unknown: 3D1606080000000000000000000000000000000000000000
                IE: Unknown: DD050050F20500
                IE: Unknown: DD720050F204104A0001101044000102103B00010310470010222102030405060708090A0B0C0D0E0F1021000842726F6164636F6D10230006536F66744150102400013010420001301054000800060050F20400011011001542726F6164636F6D2D5A51482D42434D3433333632100800020284
                IE: Unknown: DD09001018020000000000

Note The situation is normal now. I checked yesterday and speed was normal now. I am not sure how that happened but any help for future reference will be appreciated.

  • 1
    Please run the ubuntu forums wireless script (github.com/UbuntuForums/wireless-info) and paste the results into paste.ubuntu.com then edit your question to include a link to it – Steve Roome Jul 11 '16 at 17:31
  • Today I am receiving even more random downloading speed. Sometimes it rises upto 250 KB/s and than starts falling to 10 KB/s. It keeps on fluctuating. Web surfing is still normal. – Rishab Mishra Jul 12 '16 at 7:03
  • I cant see anything unusual in the results of the wireless script except the iwlist scan command did not execute. Can you disconnect from your access point and type iwlist scan into a terminal and post the results into your question. – Steve Roome Jul 14 '16 at 19:31
1

I have seen this. There are 3 causes I've found. I think most likely the problem is not in your computer.

  1. A failing network switch sitting on my desktop. It would occasionally panic and reset itself. A technician suggested replacement. To my surprise, the problem disappeared after spending $45 on a new one. If you don't have a switch, you may have a wireless router with trouble.

  2. ISP service problems. You have no way of knowing if the ISP itself is bogged down by heavy traffic among your neighbors. I work in a university library and the network slows down horribly when 100 students are watching ESPN and soap operas.

  3. Physical hardware. Water was getting inside the network cable coming into my home, causing weird, unpredictable stopages. Moisture and temperature caused unpredictable stumbles. Network did not completely fail, it was fine 9 days out of 10, but then it would slow to a crawl. Repair of a box outside solved that one. Frustrating part there was that the signal never failed completely, but it just got s-l-o-w.

Can you take your computer to a different network to find out if same problem happens again? If you can take the computer to another network, and it happens again, then you'll have information.

I guess you could have a network driver problem. Here is one thing to try. Open a terminal and run "tail -f /var/log/kern.log". Let that run as you go about your business. That will show much of same output you see in "dmesg", but maybe more specific and you see the new lines. When the network becomes slow, perhaps messages will start appearing. If your driver (a kernel module for the network device?) is failing, you'll usually see something there. You may see system disassociating itself with network and re-associating.

1

Out of curiosity, are you sure that you have a sufficient amount of data left?

Looking at the website, it looks like a paid internet service working on the same network as a phone company. Most of them will throttle your bandwidth after you have used up your limit even if you have a "unlimited" plan.

These things aren't meant to replace your Internet Provider, just a backup or if you need to check your email while traveling.

EDIT -

This is a link to the website.

https://www.tataphoton.com/en-in/photon-postpaid/loc/Delhi

it is a data allotment plan, You are most likely running up to your bandwidth allotment.

  • This would be more of a comment than an answer. Next time please add text like this as a comment. – Phil UK Mar 27 '17 at 2:04
  • Thats the problem with your system... i can't comment on anything until i have 50 points.... so how do i get points if i can't comment and i can't answer... and it was an answer... he's on a paid data allotment... most likely the case is he is being throttled. – Taynak Mar 29 '17 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.