2

My Intel 7260 bluetooth device is constanly draining battery. As per powertop:

  13.9 W    100.0%                      Device         USB device: usb-device-8087-07dc

I have both bluetooth and NFC disabled in /etc/rc.local:

rfkill block bluetooth
rfkill block nfc
/etc/init.d/bluetooth stop

And the suspend options are set as "Good" in powertop:

/sys/bus/usb/devices/3-9/power/autosuspend = 2
/sys/bus/usb/devices/3-9/power/autosuspend_delay_ms = 2000
/sys/bus/usb/devices/3-9/power/control = auto

I am using Ubuntu 16.04, kernel 4.4.0-28.

This device did not use to use so much energy before. This behaviour has only started in the last one or two months.

I have tested with a live USB Ubuntu 16.04 image and the issue does not occur in there. So, it does not seem to be a hardware issue, but a software/configuration issue.

Also, I have another computer (with the same hardware), also with Ubuntu 16.04 and kernel 4.4.0-28, which is not showing this issue.

I have tried everything I can think of: disabling bluetooth in the bluetooth applet, going back from GNOME 3.20 to GNOME 3.18 just in case, uninstalling the Nvidia proprietary driver, disabling the wifi, and upgrading to kernel 4.6.4, and putting the SSD in another computer with the same specs where this usually does not happen (so, it's not a hardware issue).

echo "3-9" | sudo tee /sys/bus/usb/drivers/usb/unbind does not stop the device from using energy as well.

How can I get this device to stop using power at 100%?

2

This is a bug in Ubuntu 16.04. I reported and it looks to be recently fixed for Ubuntu 16.10, but not yet for 16.04.

It is not related to the Intel adapter.

You can check the power management status by iwconfig.

You can enable power management manually using iwconfig, or install laptop-mode-tools, where it will be automatically set on.

Another workaround is to set power management on in Network Manager, but it is possible only per connection, that is not handy if there are many connections.

BTW I have exactly same wireless adapter ;-)

| improve this answer | |
  • Thanks for the response. However, the other computer that is not showing this issue also runs Ubuntu 16.04, also uses tlp instead of laptop-mode-tools, and uses the same version of network-manager. – Jose Gómez Jul 11 '16 at 17:13
  • It depends on the wireless/BT chip, how PM is set up. Is it for both wireless and BT or separate, etc. Try to turn on PM in iwconfig and see if that helps. – Pilot6 Jul 11 '16 at 17:15
  • ran "sudo iwconfig wlan0 power on" -no difference. – Jose Gómez Jul 11 '16 at 17:51
  • Is your interface really wlan0? Does iwconfig show PM enabled? – Pilot6 Jul 11 '16 at 17:52
  • 1
    Then it is another issue, maybe a hardware or UEFI bug with USB PM. – Pilot6 Jul 11 '16 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.