ubuntu 16.04

Image Viewer ( eog ) does not show file name. While looking around for a way to show file name I see screen shots on INTERNET that show file name at top of Viewer screen as well as in side pane. Mine shows neither. Any ideas how to get file name to display?

side pane shows: size, type, file size, folder, aperture, etc. But no filename.


I've narrowed down the problem but not solved it. With "Show the menus in the window's title bar" and "menus visibility 'Always displayed'" both selected then there is no display of the file name. Any other menus configuration and you get the file name in the window title bar. I think I would call it a bug for the filename to not be displayed anywhere under some conditions.

  • 2
    On my fresh Xenial system the filename is displayed at the top of the eog window. Perhaps reinstall: sudo apt-get remove eog && sudo apt-get install eog?
    – andrew.46
    Commented Jul 12, 2016 at 8:13
  • I am having the same issue (ubuntu 16.04 as well, I tried the reinstall). Commented Jul 22, 2016 at 11:08
  • I reinstalled but this had no effect. Commented Jul 25, 2016 at 17:20

3 Answers 3


Yes, I have several ideas. There are two other ways to display the file name for browsing images using Eye of GNOME Image Viewer, when the Unity global menu is set as "in the window's title bar" and "always displayed" in Ubuntu.

Method 1: Image Gallery

Image Gallery in Eye of GNOME

Go to View > Image Gallery (or press F9 key). The image gallery or horizontal thumbnail strip will appear at bottom of the window. Then, use mouse cursor to hover on one of the thumbnails.

A tooltip will appear somewhere near to the thumbnail image, depending on where you position the mouse cursor. The file name will appear in the first line of text with relatively large and bold font.

Method 2: Image Properties

Image Properties in Eye of GNOME

Go to Image > Image Properties (or press Alt+Return keys). The image properties window will appear at centre of the image viewer window. The file name will be shown in the first line of text as Name: FILENAME.png in the window.

Better image browsing

For better experience to browse images, use Method 2 with the tiling feature in Unity desktop environment (a.k.a Aero Snap in Windows).

  • tile the image viewer window to the left side;

  • tile the image properties window to the right side;

  • or whichever side you prefer to see the image properties with file name

Tiling Eye of GNOME and its Image Properties

Another way to browse is to maximize the image viewer window, then place the image properties window at any corner of your workspace (you can put aside the image properties window for a moment whenever it disturbs your viewing).

Image Properties at top-right corner and above Eye of GNOME

Either way, it is important to give focus on the image viewer window.

Then, use or keys (left or right arrow keys) to navigate the images. The image properties window will always stay above the image viewer window, such that file name is always visible. Else, you can click on "Previous" and "Next" buttons, should you prefer clicking (I don't).

Disclaimer: This answer intends to provide clever workarounds, without having to install any additional packages or tweaking hidden settings. That being said, these workarounds do not solve the original problem that Unity desktop environment had introduced by having such settings.


Go to System Settings -> Appearance -> Behavior and change the settings to match as shown below:


Note: The auto-hide and workspace enable settings should be non-critical. The others are important.

This has the desired result for me. Hopefully it will help you as well.

Source: Experience and testing Ubuntu 16.04 64-bit


Change the window menu placement, and the title will appear. This is normal behavior for 16.04

Go to System Settings -> Appearance -> Behavior and set Show the menus for a window to In the menu bar.

enter image description here

  • I have already tried that setting, but that setting is not suitable. Is there a way to still get the file name.
    – hunch
    Commented Aug 10, 2016 at 12:33
  • @hunch well , i don't exactly understand what do you mean "still get the filename" ? how do you want it to display ? you said you found images online. Can you provide one of them as example ? Commented Aug 10, 2016 at 18:47
  • If the setting is set to "in the menu bar" the title shows (at least for me). If the setting is "in the windows title bar" the title disappears if the mouse pointer is over the title bar to allow the menu to be shown but otherwise the title still shows.
    – Elder Geek
    Commented Aug 10, 2016 at 20:44
  • @ElderGeek yes, that's the proper behavior. The Show the menu for a window options and Menu visibility work together. I've set mine to In the window's title bar and Displayed on mouse hovering. That way I have best of both worlds - title is there and menu is there , if i need it. Commented Aug 10, 2016 at 20:57
  • That sounds like a key piece of this answer. The OP may have Always displayed flipped on.
    – Elder Geek
    Commented Aug 10, 2016 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .