6

FSCK is running every boot on Ubuntu 16.04. How can I prevent this from happening? I've searched boot parameters and don't see any parameter setting this to be run on boot. Also, there is no /forcefsck file.

9

In /etc/fstab, for every entry, change the last parameter (a digit, usually 0, 1, or 2) to 0

  • 1 will run fsck first on this partition at boot
  • 2 will run fsck next after 1 at boot
  • 0 will not run fsck on boot

According to the fstab documentation:

Controls the order in which fsck checks the device/partition for errors at boot time. The root device should be 1. Other partitions should be 2, or 0 to disable checking.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.