2

When I had 12.04 LTS, pdfsam worked great. Now with 16.04 LTS, when I install pdfsam from the Ubuntu Software Center, the pdfsam icon appears in the launcher and the Software Center still shows the INSTALL button for pdfsam which I guess means pdfsam has not been installed. If I click on the pdfsam launcher icon, it fails...Sorry, Ubuntu 16.04 has experienced an internal error. Also, an error log file is created that begins with "A fatal error has been detected by the Java Runtime Environment". How should I proceed?

  • Correction: The Software Center list of installed apps now shows that pdfsam is installed. It says that I have version 1.1.4-2 installed. But it still fails when I try to run it. – user517647 Jul 11 '16 at 2:34
2

pdfsam just doesn't work on 16.04. Live with that and try another pdf app like : PDF MOD, PDF Shuffler, PDF Chain or even Master PDF Editor (probably the best pdf editor in linux). I personally prefer Foxit PDF Editor which works well under Wine.

1

I had the same experience. It worked fine before upgrading to 16.04, but not after. I got it to work again by installing a newer version of the Java JRE and then telling the launcher to use the new JRE. I installed the Java JRE from Oracle (you can get it at java.com).

To tell pdfsam to use the new Java, edit the file at /usr/bin/pdfsam (you might need to do this as root). In the file on my machine, at line 36 I added this:

JAVA=/home/mike/java/jre1.8.0_101/bin/java

Note that I installed the Java JRE in my home directory. Maybe not the best place to do it, but I'm the only person using this machine so this works fine for me. You'll need to change the line above to whatever location you chose to install the JRE to.

The old Java JRE is still on my machine for any programs that still need it, so this should not affect anything else you have going on your computer.

Good luck!

1

In my case the problem was related to the fact that ubuntu 16.04 uses openjdk 9 by default but installing jdk 8 made the trick. Here's what I did after installing the malfunctioning pdfsam:

# apt-get install python-software-properties
# add-apt-repository ppa:webupd8team/java
# apt-get update
# apt-get install oracle-java8-installer

...and welcome back your lovely pdfsam

  • This works and should be marked as the answer now. – rgin Sep 4 '18 at 1:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.