4

I'm pretty new in the world of KDE but chose to give Kubuntu 16.04 a try on both my Desktop and my Laptop. Both are fairly recent installations and haven't been modified that much.

Now for my problem:

I simply wanted to change my theme to a dark one in the System Settings. So I went to Workspace Theme > Look & Feel and clicked on "Breeze Dark". So far so easy. But something is not right.

The task bar changes, the plasma search bar changes and e.g. the background of the dolphin main view changes. But that's it. The system settings window is still white, the dolphin sidebar is still white, other qt apps (that should be affected by the theme change) still remain white. Even multiple restarts didn't help anything...

Here is a screenshot of dolphin so you can see what I mean:

Screenshot

The issue appears on both Desktop and Laptop which should exclude a hardware fault. Maybe I've done something wrong during installation.

I hope anyone can at least give me a hint of what I might've done wrong or how to gain additional information. Nobody on the entire Internet seems to have the same problem as far as Google is concerned.

System Specs (in case needed):

  • Kubuntu 16.04
  • KDE Plasma Version (Desktop): 5.6.5 (upgraded it in the hope of fixing the issue)
  • Screenshot of "About System" Screen for additional information:

Screenshot

EDIT: Ah, of course, just after posting the question I found someone with a similar problem (if not exactly the same). But the solution didn't work for me as I've already tried updating Plasma.

0

2 Answers 2

2

Anwar answered in this post:

I'm guessing you've installed some other GTK based Desktop Environments (Such as Lubuntu or Xubuntu) in your Kubuntu installation. Though the theme changes, they revert back to the ugly Striped look after a reboot.The solution is installing gtk3-engines-breeze.

sudo apt-get install gtk3-engines-breeze kde-config-gtk-style

After installing, Open System Settings -> Application Style -> Gnome Application Style and Change the theme for both Gtk2 and Gtk3 to Breeze Dark.

If the theme don't change immediately after applying:

If all the theme component doesn't change to Breeze Dark immediately, Go to Settings -> Workspace Theme and select Breeze Theme by clicking it, this will activate the Apply button. Now, change the selection back to Breeze Dark Theme by clicking it and finally Click the Apply Button.

I had the same problem as you, but already had gtk3-engines-breeze, and switching to breeze dark in gnome application settings worked for me.

Hope it helps.

0

Change back to Breeze and then back again to Breeze Dark. If that doesn't fix it, go through every category and change them all to breeze dark (including color and icons)

1
  • I did both, but it hasn't changed anything. The main problem (i guess) is that if I change the Color Scheme to Breeze dark, it doesn't get applied everywhere
    – LeoDJ
    Jul 12, 2016 at 19:50

Not the answer you're looking for? Browse other questions tagged .