1

Edit: Network Settings finally opened and has given me a message saying "The system network services are not compatible with this version". Is this because I updated through Ubuntu Software before I left?

Just came back from a LAN event and I'm unable to connect back to my home WiFi. Once I'm logged into my account there is no Network icon in the top right corner and when I load system settings and attempt to navigate to the Network settings the window becomes unresponsive. New to Ubuntu and typing this out on mobile so this may take some time.

Edit: When attempting to ping a web address I get ping: unknown host google.com

But when I ping the IP I get.

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data

64 bytes from 8.8.8.8: ICMP_seq=1 ttl=44 time=39.8 ms

Etcetera

However when doing the command nslookup google.com I get

; ; connection timed out; no servers could be reached

Upon reboot of PC the network icon is visible in the top right but when trying to connect to the network through that yields the message: Failed to add/activate connection (1) Insufficient privileges

The icon vanishes as soon as I log in

Within /etc/resolv.conf all there is is a line that states

nameserver  127.0.1.1

Dig yields

    dig @8.8.8.8 askubuntu.com
; <<>> DiG 9.10.3-P4-Ubuntu <<>> @8.8.8.8 askubuntu.com
; (1 server found)
;; global options +cmd
;; Got answer :
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34398
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSUEDOSECTION:
; EDNS: version 0, flags : ; udp  512
;; QUESTION SECTION:
;askubuntu.com.          IN            A

;;ANSWER SECTION:
askubuntu.com.     112   IN            A     151.101.65.69
askubuntu.com.     112   IN            A     151.101.1.69
askubuntu.com.     112   IN            A     151.101.193.69
askubuntu.com.     113   IN            A     151.101.129.69

;; Query time: 42 msec
;; SERVER 8.8.8.8#53(8.8.8.8)
;; WHEN: Sun Jul 10 16:46:38 EDT 2016
;; MSG SIZE rcvd: 106
  • Have you tried to reboot? Have you tried to reboot your Wifi router? – wk. Jul 10 '16 at 19:31
  • Rebooting the PC has had no effect, will reboot router and update. Router reboot did nothing. – ELOwoozle Jul 10 '16 at 19:33
0

I have no idea, what is wrong with your NetworkManager, but if you can ping by IP, it means you have connected and having problems with name resolution. You should look what is in /etc/resolv.conf or try to use name resolution from command line with alternate DNS, like:

$ dig @8.8.8.8 askubuntu.com

Other ideas base your edit:

  • remove connection and recreate it
  • create temporary user, log in and try, how networking acts there
  • Temporary user has the same issues, unsure how to recreate the connection. – ELOwoozle Jul 10 '16 at 19:58
  • What should be in resolv. – ELOwoozle Jul 11 '16 at 1:01
  • Decided to take a nuclear option and just reinstalled the OS. I think it may have been a system update I downloaded didn't fetch the right drivers - honestly though I haven't a clue. Having reinstalled the OS though I'm having no problems. – ELOwoozle Jul 20 '16 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.